ISIS, OSPF3 and RIP(ng).

While I was going over IS-IS, I felt like doing a lab with it and make IS-IS route for both IPv4 and IPv6. I then though it would be nice to dedicate a small part of the lab to OSPF3 and have that routing protocol distribute prefix information for both IPV6 and IPv4 as well. To top it of, I wanted to do some redistribution between IS-IS and OSPF3.

It was kind of fun. Most probably there are some best practices I did not follow and surely there are several things I missed. My general goal, however, of establishing IP(v6) connectivity between the loopback IP addresses of all the routers was accomplished.

Besides the whole IPv4/IPv6 thing in IS-IS and OSPF3, I also wanted to repeat the basic IS-IS stuff in this lab. So there is some summarization, there is another area, there is some IS-IS interface authentication, some IS-IS level 2 authentication for all packets, redistribution of RIP(ng), some recommended best-practices (LSP lifetime, spf-delay and overload timeout) and some other OSPF3 stuff.

At the end of the lab all routers were able to ping each other and I had fun doing this. I decided to keep the lab available for future references by putting it up on this website.

scenario
Zoom in.

AURELIUS:
 
set interfaces xe-0/2/0 unit 2 description REMUS
set interfaces xe-0/2/0 unit 2 vlan-id 2
set interfaces xe-0/2/0 unit 2 family inet mtu 1500
set interfaces xe-0/2/0 unit 2 family inet address 2.0.0.6/30
set interfaces xe-0/2/0 unit 2 family iso
set interfaces xe-0/2/0 unit 2 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 2 family inet6 address 2001:2:5::/64 eui-64
set interfaces xe-0/2/0 unit 2 family inet6 address fe80::0002:0000:0000:0001/64
set interfaces xe-0/3/0 unit 4 description TRAJAN
set interfaces xe-0/3/0 unit 4 vlan-id 4
set interfaces xe-0/3/0 unit 4 family inet mtu 1500
set interfaces xe-0/3/0 unit 4 family inet address 2.0.0.13/30
set interfaces xe-0/3/0 unit 4 family iso
set interfaces xe-0/3/0 unit 4 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 4 family inet6 address 2001:2:13::/64 eui-64
set interfaces xe-0/3/0 unit 4 family inet6 address fe80::0004:0000:0000:0001/64
set interfaces lo0 unit 1 family inet address 1.1.1.1/32
set interfaces lo0 unit 1 family inet6 address 2001::1/128
set protocols rip group RIP export RIP-EXPORT
set protocols rip group RIP neighbor xe-0/3/0.4
set protocols rip group RIP neighbor xe-0/2/0.2
set protocols ripng group RIPNG export RIPNG-EXPORT
set protocols ripng group RIPNG neighbor xe-0/3/0.4
set protocols ripng group RIPNG neighbor xe-0/2/0.2
set policy-options policy-statement RIP-EXPORT from protocol direct
set policy-options policy-statement RIP-EXPORT from protocol rip
set policy-options policy-statement RIP-EXPORT then accept
set policy-options policy-statement RIPNG-EXPORT from protocol direct
set policy-options policy-statement RIPNG-EXPORT from protocol ripng
set policy-options policy-statement RIPNG-EXPORT then accept
                
TRAJAN:
 
set interfaces xe-0/2/0 unit 4 description AURELIUS
set interfaces xe-0/2/0 unit 4 vlan-id 4
set interfaces xe-0/2/0 unit 4 family inet mtu 1500
set interfaces xe-0/2/0 unit 4 family inet address 2.0.0.14/30
set interfaces xe-0/2/0 unit 4 family iso
set interfaces xe-0/2/0 unit 4 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 4 family inet6 address 2001:2:13::/64 eui-64
set interfaces xe-0/2/0 unit 4 family inet6 address fe80::0004:0000:0000:0002/64
set interfaces xe-0/2/0 unit 5 description ROMULUS
set interfaces xe-0/2/0 unit 5 vlan-id 5
set interfaces xe-0/2/0 unit 5 family inet mtu 1500
set interfaces xe-0/2/0 unit 5 family inet address 2.0.0.18/30
set interfaces xe-0/2/0 unit 5 family iso
set interfaces xe-0/2/0 unit 5 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 5 family inet6 address 2001:2:17::/64 eui-64
set interfaces xe-0/2/0 unit 5 family inet6 address fe80::0005:0000:0000:0002/64
set interfaces lo0 unit 2 family inet address 1.1.1.2/32
set interfaces lo0 unit 2 family inet6 address 2001::2/128
set protocols rip group RIP export RIP-EXPORT
set protocols rip group RIP neighbor xe-0/2/0.4
set protocols rip group RIP neighbor xe-0/2/0.5
set protocols ripng group RIPNG export RIPNG-EXPORT
set protocols ripng group RIPNG neighbor xe-0/2/0.4
set protocols ripng group RIPNG neighbor xe-0/2/0.5
set policy-options policy-statement RIP-EXPORT from protocol direct
set policy-options policy-statement RIP-EXPORT from protocol rip
set policy-options policy-statement RIP-EXPORT then accept
set policy-options policy-statement RIPNG-EXPORT from protocol direct
set policy-options policy-statement RIPNG-EXPORT from protocol ripng
set policy-options policy-statement RIPNG-EXPORT then accept
                
REMUS:
 
set interfaces xe-0/3/0 unit 1 description ROMULUS
set interfaces xe-0/3/0 unit 1 vlan-id 1
set interfaces xe-0/3/0 unit 1 family inet mtu 1500
set interfaces xe-0/3/0 unit 1 family inet address 2.0.0.1/30
set interfaces xe-0/3/0 unit 1 family iso
set interfaces xe-0/3/0 unit 1 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 1 family inet6 address 2001:2:1::/64 eui-64
set interfaces xe-0/3/0 unit 1 family inet6 address fe80::0001:0000:0000:0004/64
set interfaces xe-0/3/0 unit 2 description AURELIUS
set interfaces xe-0/3/0 unit 2 vlan-id 2
set interfaces xe-0/3/0 unit 2 family inet mtu 1500
set interfaces xe-0/3/0 unit 2 family inet address 2.0.0.5/30
set interfaces xe-0/3/0 unit 2 family iso
set interfaces xe-0/3/0 unit 2 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 2 family inet6 address 2001:2:5::/64 eui-64
set interfaces xe-0/3/0 unit 2 family inet6 address fe80::0002:0000:0000:0004/64
set interfaces xe-0/3/0 unit 3 description TIBERIUS
set interfaces xe-0/3/0 unit 3 vlan-id 3
set interfaces xe-0/3/0 unit 3 family inet mtu 1500
set interfaces xe-0/3/0 unit 3 family inet address 2.0.0.9/30
set interfaces xe-0/3/0 unit 3 family iso
set interfaces xe-0/3/0 unit 3 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 3 family inet6 address 2001:2:9::/64 eui-64
set interfaces xe-0/3/0 unit 3 family inet6 address fe80::0003:0000:0000:0004/64
set interfaces lo0 unit 5 family inet address 1.1.1.5/32
set interfaces lo0 unit 5 family iso address 49.0002.0000.0000.0005.00
set interfaces lo0 unit 5 family inet6 address 2001::5/128
set protocols isis export IS-IS-EXPORT
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$UkHqPF3/9AuRhWX7V2g"
set protocols isis level 2 authentication-type md5
set protocols isis level 2 wide-metrics-only
set protocols isis level 1 wide-metrics-only
set protocols isis interface xe-0/3/0.1 point-to-point
set protocols isis interface xe-0/3/0.1 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.1 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/3/0.1 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/3/0.1 level 1 disable
set protocols isis interface xe-0/3/0.3 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.3 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/3/0.3 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/3/0.3 level 2 disable
set protocols isis interface xe-0/3/0.3 level 1 hello-authentication-key "$9$QvFjn/AB1EhSl8XY4aUkq"
set protocols isis interface xe-0/3/0.3 level 1 hello-authentication-type md5
set protocols isis interface lo0.5
set protocols rip group RIP export RIP-EXPORT
set protocols rip group RIP neighbor xe-0/3/0.2
set protocols ripng group RIPNG export RIPNG-EXPORT
set protocols ripng group RIPNG neighbor xe-0/3/0.2
set policy-options policy-statement IS-IS-EXPORT term RIP from protocol rip
set policy-options policy-statement IS-IS-EXPORT term RIP then tag 1000
set policy-options policy-statement IS-IS-EXPORT term RIP then accept
set policy-options policy-statement IS-IS-EXPORT term RIPNG from protocol ripng
set policy-options policy-statement IS-IS-EXPORT term RIPNG then tag 1000
set policy-options policy-statement IS-IS-EXPORT term RIPNG then accept
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-SUMMARIZATION from protocol aggregate
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-SUMMARIZATION from route-filter 45.0.0.0/22 exact
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-SUMMARIZATION to level 2
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-SUMMARIZATION then accept
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-CONTRIBUTOR-REJECT from aggregate-contributor
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-CONTRIBUTOR-REJECT to level 2
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-CONTRIBUTOR-REJECT then reject
set policy-options policy-statement RIP-EXPORT term DENY-ISIS from protocol isis
set policy-options policy-statement RIP-EXPORT term DENY-ISIS from tag 1000
set policy-options policy-statement RIP-EXPORT term DENY-ISIS then reject
set policy-options policy-statement RIP-EXPORT term ISIS from protocol isis
set policy-options policy-statement RIP-EXPORT term ISIS then tag 1000
set policy-options policy-statement RIP-EXPORT term ISIS then accept
set policy-options policy-statement RIP-EXPORT term DIRECT from protocol direct
set policy-options policy-statement RIP-EXPORT term DIRECT then accept
set policy-options policy-statement RIPNG-EXPORT term DENY-ISIS from protocol isis
set policy-options policy-statement RIPNG-EXPORT term DENY-ISIS from tag 1000
set policy-options policy-statement RIPNG-EXPORT term DENY-ISIS then reject
set policy-options policy-statement RIPNG-EXPORT term ISIS from protocol isis
set policy-options policy-statement RIPNG-EXPORT term ISIS then tag 1000
set policy-options policy-statement RIPNG-EXPORT term ISIS then accept
set policy-options policy-statement RIPNG-EXPORT term DIRECT from protocol direct
set policy-options policy-statement RIPNG-EXPORT term DIRECT then accept
set routing-options aggregate route 45.0.0.0/22
                
ROMULUS:
 
set interfaces xe-0/2/0 unit 1 description REMUS
set interfaces xe-0/2/0 unit 1 vlan-id 1
set interfaces xe-0/2/0 unit 1 family inet mtu 1500
set interfaces xe-0/2/0 unit 1 family inet address 2.0.0.2/30
set interfaces xe-0/2/0 unit 1 family iso
set interfaces xe-0/2/0 unit 1 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 1 family inet6 address 2001:2:1::/64 eui-64
set interfaces xe-0/2/0 unit 1 family inet6 address fe80::0001:0000:0000:0006/64
set interfaces xe-0/2/0 unit 10 description HADRIAN
set interfaces xe-0/2/0 unit 10 vlan-id 10
set interfaces xe-0/2/0 unit 10 family inet mtu 1500
set interfaces xe-0/2/0 unit 10 family inet address 2.0.0.38/30
set interfaces xe-0/2/0 unit 10 family iso
set interfaces xe-0/2/0 unit 10 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 10 family inet6 address 2001:2:37::/64 eui-64
set interfaces xe-0/2/0 unit 10 family inet6 address fe80::0010:0000:0000:0006/64
set interfaces xe-0/2/0 unit 13 description AUGUSTUS
set interfaces xe-0/2/0 unit 13 vlan-id 13
set interfaces xe-0/2/0 unit 13 family inet mtu 1500
set interfaces xe-0/2/0 unit 13 family inet address 2.0.0.50/30
set interfaces xe-0/2/0 unit 13 family iso
set interfaces xe-0/2/0 unit 13 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 13 family inet6 address 2001:2:49::/64 eui-64
set interfaces xe-0/2/0 unit 13 family inet6 address fe80::0013:0000:0000:0006/64
set interfaces xe-0/3/0 unit 5 description TRAJAN
set interfaces xe-0/3/0 unit 5 vlan-id 5
set interfaces xe-0/3/0 unit 5 family inet mtu 1500
set interfaces xe-0/3/0 unit 5 family inet address 2.0.0.17/30
set interfaces xe-0/3/0 unit 5 family iso
set interfaces xe-0/3/0 unit 5 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 5 family inet6 address 2001:2:17::/64 eui-64
set interfaces xe-0/3/0 unit 5 family inet6 address fe80::0005:0000:0000:0006/64
set interfaces lo0 unit 6 family inet address 1.1.1.6/32
set interfaces lo0 unit 6 family iso address 49.0001.0000.0000.0006.00
set interfaces lo0 unit 6 family inet6 address 2001::6/128
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$UkHqPF3/9AuRhWX7V2g"
set protocols isis level 2 authentication-type md5
set protocols isis level 2 wide-metrics-only
set protocols isis interface xe-0/2/0.1 point-to-point
set protocols isis interface xe-0/2/0.1 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.1 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/2/0.1 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/2/0.1 level 1 disable
set protocols isis interface xe-0/2/0.10 point-to-point
set protocols isis interface xe-0/2/0.10 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.10 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/2/0.10 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/2/0.10 level 1 disable
set protocols isis interface xe-0/2/0.13 point-to-point
set protocols isis interface xe-0/2/0.13 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.13 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/2/0.13 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/2/0.13 level 1 disable
set protocols isis interface lo0.6
set protocols rip group RIP export RIP-EXPORT
set protocols rip group RIP neighbor xe-0/3/0.5
set protocols ripng group RIPNG preference 200
set protocols ripng group RIPNG export RIPNG-EXPORT
set protocols ripng group RIPNG neighbor xe-0/3/0.5
set policy-options policy-statement IS-IS-EXPORT term RIP from protocol rip
set policy-options policy-statement IS-IS-EXPORT term RIP then tag 1000
set policy-options policy-statement IS-IS-EXPORT term RIP then accept
set policy-options policy-statement IS-IS-EXPORT term RIPNG from protocol ripng
set policy-options policy-statement IS-IS-EXPORT term RIPNG then tag 1000
set policy-options policy-statement IS-IS-EXPORT term RIPNG then accept
set policy-options policy-statement RIP-EXPORT term DENY-ISIS from protocol isis
set policy-options policy-statement RIP-EXPORT term DENY-ISIS from tag 1000
set policy-options policy-statement RIP-EXPORT term DENY-ISIS then reject
set policy-options policy-statement RIP-EXPORT term ISIS from protocol isis
set policy-options policy-statement RIP-EXPORT term ISIS then tag 1000
set policy-options policy-statement RIP-EXPORT term ISIS then accept
set policy-options policy-statement RIP-EXPORT term DIRECT from protocol direct
set policy-options policy-statement RIP-EXPORT term DIRECT then accept
set policy-options policy-statement RIPNG-EXPORT term DENY-ISIS from protocol isis
set policy-options policy-statement RIPNG-EXPORT term DENY-ISIS from tag 1000
set policy-options policy-statement RIPNG-EXPORT term DENY-ISIS then reject
set policy-options policy-statement RIPNG-EXPORT term ISIS from protocol isis
set policy-options policy-statement RIPNG-EXPORT term ISIS then tag 1000
set policy-options policy-statement RIPNG-EXPORT term ISIS then accept
set policy-options policy-statement RIPNG-EXPORT term DIRECT from protocol direct
set policy-options policy-statement RIPNG-EXPORT term DIRECT then accept
                
AUGUSTUS:
 
set apply-groups SA
set interfaces xe-0/2/0 unit 7 description GAIUS
set interfaces xe-0/2/0 unit 7 vlan-id 7
set interfaces xe-0/2/0 unit 7 family inet mtu 1500
set interfaces xe-0/2/0 unit 7 family inet address 2.0.0.26/30
set interfaces xe-0/2/0 unit 7 family iso
set interfaces xe-0/2/0 unit 7 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 7 family inet6 address 2001:2:25::/64 eui-64
set interfaces xe-0/2/0 unit 7 family inet6 address fe80::0007:0000:0000:0007/64
set interfaces xe-0/2/0 unit 15 description CALIGULA
set interfaces xe-0/2/0 unit 15 vlan-id 15
set interfaces xe-0/2/0 unit 15 family inet mtu 1500
set interfaces xe-0/2/0 unit 15 family inet address 2.0.0.58/30
set interfaces xe-0/2/0 unit 15 family iso
set interfaces xe-0/2/0 unit 15 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 15 family inet6 address 2001:2:57::/64 eui-64
set interfaces xe-0/2/0 unit 15 family inet6 address fe80::0015:0000:0000:0007/64
set interfaces xe-0/3/0 unit 12 description NERO
set interfaces xe-0/3/0 unit 12 vlan-id 12
set interfaces xe-0/3/0 unit 12 family inet mtu 1500
set interfaces xe-0/3/0 unit 12 family inet address 2.0.0.45/30
set interfaces xe-0/3/0 unit 12 family iso
set interfaces xe-0/3/0 unit 12 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 12 family inet6 address 2001:2:45::/64 eui-64
set interfaces xe-0/3/0 unit 12 family inet6 address fe80::0012:0000:0000:0007/64
set interfaces xe-0/3/0 unit 13 description ROMULUS
set interfaces xe-0/3/0 unit 13 vlan-id 13
set interfaces xe-0/3/0 unit 13 family inet mtu 1500
set interfaces xe-0/3/0 unit 13 family inet address 2.0.0.49/30
set interfaces xe-0/3/0 unit 13 family iso
set interfaces xe-0/3/0 unit 13 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 13 family inet6 address 2001:2:49::/64 eui-64
set interfaces xe-0/3/0 unit 13 family inet6 address fe80::0013:0000:0000:0007/64
set interfaces lo0 unit 7 family inet address 1.1.1.7/32
set interfaces lo0 unit 7 family iso address 49.0001.0000.0000.0007.00
set interfaces lo0 unit 7 family inet6 address 2001::7/128
set protocols isis export ISIS-EXPORT
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$UkHqPF3/9AuRhWX7V2g"
set protocols isis level 2 authentication-type md5
set protocols isis level 2 wide-metrics-only
set protocols isis interface xe-0/3/0.12 point-to-point
set protocols isis interface xe-0/3/0.12 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.12 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/3/0.12 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/3/0.12 level 1 disable
set protocols isis interface xe-0/3/0.13 point-to-point
set protocols isis interface xe-0/3/0.13 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.13 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/3/0.13 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/3/0.13 level 1 disable
set protocols isis interface lo0.7
set protocols ospf3 realm ipv4-unicast export OSPF3-EXPORT-INET
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/2/0.15 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/2/0.7 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.7 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.7 passive
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/2/0.13 passive
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/3/0.12 passive
set protocols ospf3 export OSPF3-EXPORT-INET6
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.15 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.15 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.7 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.7 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface lo0.7
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.13 passive
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.12 passive
set policy-options policy-statement ISIS-EXPORT term OSPF3-ACCEPT from protocol ospf3
set policy-options policy-statement ISIS-EXPORT term OSPF3-ACCEPT then accept
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet from family inet
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet from protocol static
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet then accept
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 from family inet6
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 from protocol static
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 then accept
set routing-options rib inet6.0 static route ::/0 reject
set routing-options static route 0.0.0.0/0 reject
set routing-options router-id 1.1.1.7
                
TIBERIUS:
 
set interfaces xe-0/2/0 unit 3 description REMUS
set interfaces xe-0/2/0 unit 3 vlan-id 3
set interfaces xe-0/2/0 unit 3 family inet mtu 1500
set interfaces xe-0/2/0 unit 3 family inet address 2.0.0.10/30
set interfaces xe-0/2/0 unit 3 family iso
set interfaces xe-0/2/0 unit 3 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 3 family inet6 address 2001:2:9::/64 eui-64
set interfaces xe-0/2/0 unit 3 family inet6 address fe80::0003:0000:0000:0013/64
set interfaces xe-0/2/0 unit 9 description HADRIAN
set interfaces xe-0/2/0 unit 9 vlan-id 9
set interfaces xe-0/2/0 unit 9 family inet mtu 1500
set interfaces xe-0/2/0 unit 9 family inet address 2.0.0.34/30
set interfaces xe-0/2/0 unit 9 family iso
set interfaces xe-0/2/0 unit 9 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 9 family inet6 address 2001:2:33::/64 eui-64
set interfaces xe-0/2/0 unit 9 family inet6 address fe80::0009:0000:0000:0013/64
set interfaces xe-0/2/0 unit 18 description HADRIAN_VESPASIAN
set interfaces xe-0/2/0 unit 18 vlan-id 18
set interfaces xe-0/2/0 unit 18 family inet mtu 1500
set interfaces xe-0/2/0 unit 18 family inet address 3.0.0.2/29
set interfaces xe-0/2/0 unit 18 family iso
set interfaces xe-0/2/0 unit 18 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 18 family inet6 address 2001:3:1::/64 eui-64
set interfaces xe-0/2/0 unit 18 family inet6 address fe80::0018:0000:0000:0009/64
set interfaces lo0 unit 9 family inet address 1.1.1.9/32
set interfaces lo0 unit 9 family iso address 49.0002.0000.0000.0009.00
set interfaces lo0 unit 9 family inet6 address 2001::9/128
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 1 wide-metrics-only
set protocols isis interface xe-0/2/0.3 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.3 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/2/0.3 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/2/0.3 level 2 disable
set protocols isis interface xe-0/2/0.3 level 1 hello-authentication-key "$9$QvFjn/AB1EhSl8XY4aUkq"
set protocols isis interface xe-0/2/0.3 level 1 hello-authentication-type md5
set protocols isis interface xe-0/2/0.9 point-to-point
set protocols isis interface xe-0/2/0.9 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.9 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/2/0.9 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/2/0.9 level 2 disable
set protocols isis interface xe-0/2/0.9 level 1 hello-authentication-key "$9$QvFjn/AB1EhSl8XY4aUkq"
set protocols isis interface xe-0/2/0.9 level 1 hello-authentication-type md5
set protocols isis interface xe-0/2/0.18 level 2 disable
set protocols isis interface xe-0/2/0.18 level 1 hello-authentication-key "$9$QvFjn/AB1EhSl8XY4aUkq"
set protocols isis interface xe-0/2/0.18 level 1 hello-authentication-type md5
set protocols isis interface lo0.9
                
HADRIAN:
 
set interfaces xe-0/3/0 unit 9 description TIBERIUS
set interfaces xe-0/3/0 unit 9 vlan-id 9
set interfaces xe-0/3/0 unit 9 family inet mtu 1500
set interfaces xe-0/3/0 unit 9 family inet address 2.0.0.33/30
set interfaces xe-0/3/0 unit 9 family iso
set interfaces xe-0/3/0 unit 9 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 9 family inet6 address 2001:2:33::/64 eui-64
set interfaces xe-0/3/0 unit 9 family inet6 address fe80::0009:0000:0000:0010/64
set interfaces xe-0/3/0 unit 10 description ROMULUS
set interfaces xe-0/3/0 unit 10 vlan-id 10
set interfaces xe-0/3/0 unit 10 family inet mtu 1500
set interfaces xe-0/3/0 unit 10 family inet address 2.0.0.37/30
set interfaces xe-0/3/0 unit 10 family iso
set interfaces xe-0/3/0 unit 10 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 10 family inet6 address 2001:2:37::/64 eui-64
set interfaces xe-0/3/0 unit 10 family inet6 address fe80::0010:0000:0000:0010/64
set interfaces xe-0/3/0 unit 11 description NERO
set interfaces xe-0/3/0 unit 11 vlan-id 11
set interfaces xe-0/3/0 unit 11 family inet mtu 1500
set interfaces xe-0/3/0 unit 11 family inet address 2.0.0.41/30
set interfaces xe-0/3/0 unit 11 family iso
set interfaces xe-0/3/0 unit 11 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 11 family inet6 address 2001:2:41::/64 eui-64
set interfaces xe-0/3/0 unit 11 family inet6 address fe80::0011:0000:0000:0010/64
set interfaces xe-0/3/0 unit 18 description TIBERIUS_HADRIAN
set interfaces xe-0/3/0 unit 18 vlan-id 18
set interfaces xe-0/3/0 unit 18 family inet mtu 1500
set interfaces xe-0/3/0 unit 18 family inet address 3.0.0.1/29
set interfaces xe-0/3/0 unit 18 family iso
set interfaces xe-0/3/0 unit 18 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 18 family inet6 address 2001:3:1::/64 eui-64
set interfaces xe-0/3/0 unit 18 family inet6 address fe80::0018:0000:0000:0010/64
set interfaces lo0 unit 10 family inet address 1.1.1.10/32
set interfaces lo0 unit 10 family iso address 49.0002.0000.0000.0010.00
set interfaces lo0 unit 10 family inet6 address 2001::10/128
set protocols isis export IS-IS-EXPORT
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$UkHqPF3/9AuRhWX7V2g"
set protocols isis level 2 authentication-type md5
set protocols isis level 2 wide-metrics-only
set protocols isis level 1 wide-metrics-only
set protocols isis interface xe-0/3/0.9 point-to-point
set protocols isis interface xe-0/3/0.9 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.9 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/3/0.9 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/3/0.9 level 2 disable
set protocols isis interface xe-0/3/0.9 level 1 hello-authentication-key "$9$QvFjn/AB1EhSl8XY4aUkq"
set protocols isis interface xe-0/3/0.9 level 1 hello-authentication-type md5
set protocols isis interface xe-0/3/0.10 point-to-point
set protocols isis interface xe-0/3/0.10 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.10 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/3/0.10 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/3/0.10 level 1 disable
set protocols isis interface xe-0/3/0.11 point-to-point
set protocols isis interface xe-0/3/0.11 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.11 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/3/0.11 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/3/0.11 level 1 disable
set protocols isis interface xe-0/3/0.18 level 2 disable
set protocols isis interface xe-0/3/0.18 level 1 hello-authentication-key "$9$QvFjn/AB1EhSl8XY4aUkq"
set protocols isis interface xe-0/3/0.18 level 1 hello-authentication-type md5
set protocols isis interface lo0.10
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-SUMMARIZATION from protocol aggregate
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-SUMMARIZATION from route-filter 45.0.0.0/22 exact
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-SUMMARIZATION to level 2
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-SUMMARIZATION then accept
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-CONTRIBUTOR-REJECT from aggregate-contributor
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-CONTRIBUTOR-REJECT to level 2
set policy-options policy-statement IS-IS-EXPORT term AGGREGATE-CONTRIBUTOR-REJECT then reject
set routing-options aggregate route 45.0.0.0/22
                
NERO:
 
set apply-groups SA
set interfaces xe-0/2/0 unit 11 description HADRIAN
set interfaces xe-0/2/0 unit 11 vlan-id 11
set interfaces xe-0/2/0 unit 11 family inet mtu 1500
set interfaces xe-0/2/0 unit 11 family inet address 2.0.0.42/30
set interfaces xe-0/2/0 unit 11 family iso
set interfaces xe-0/2/0 unit 11 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 11 family inet6 address 2001:2:41::/64 eui-64
set interfaces xe-0/2/0 unit 11 family inet6 address fe80::0011:0000:0000:0011/64
set interfaces xe-0/2/0 unit 12 description AUGUSTUS
set interfaces xe-0/2/0 unit 12 vlan-id 12
set interfaces xe-0/2/0 unit 12 family inet mtu 1500
set interfaces xe-0/2/0 unit 12 family inet address 2.0.0.46/30
set interfaces xe-0/2/0 unit 12 family iso
set interfaces xe-0/2/0 unit 12 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 12 family inet6 address 2001:2:45::/64 eui-64
set interfaces xe-0/2/0 unit 12 family inet6 address fe80::0012:0000:0000:0011/64
set interfaces xe-0/3/0 unit 17 description SEPTIMUS
set interfaces xe-0/3/0 unit 17 vlan-id 17
set interfaces xe-0/3/0 unit 17 family inet mtu 1500
set interfaces xe-0/3/0 unit 17 family inet address 2.0.0.65/30
set interfaces xe-0/3/0 unit 17 family iso
set interfaces xe-0/3/0 unit 17 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 17 family inet6 address 2001:2:65::/64 eui-64
set interfaces xe-0/3/0 unit 17 family inet6 address fe80:17::2/64
set interfaces lo0 unit 11 family inet address 1.1.1.11/32
set interfaces lo0 unit 11 family iso address 49.0001.0000.0000.0011.00
set interfaces lo0 unit 11 family inet6 address 2001::11/128
set protocols isis export ISIS-EXPORT
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$UkHqPF3/9AuRhWX7V2g"
set protocols isis level 2 authentication-type md5
set protocols isis level 2 wide-metrics-only
set protocols isis interface xe-0/2/0.11 point-to-point
set protocols isis interface xe-0/2/0.11 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.11 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/2/0.11 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/2/0.11 level 1 disable
set protocols isis interface xe-0/2/0.12 point-to-point
set protocols isis interface xe-0/2/0.12 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.12 bfd-liveness-detection minimum-interval 3000
set protocols isis interface xe-0/2/0.12 bfd-liveness-detection multiplier 10
set protocols isis interface xe-0/2/0.12 level 1 disable
set protocols isis interface lo0.11
set protocols ospf3 realm ipv4-unicast external-preference 10
set protocols ospf3 realm ipv4-unicast export OSPF3-EXPORT-INET
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/3/0.17 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.11 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.11 passive
set protocols ospf3 external-preference 50
set protocols ospf3 export OSPF3-EXPORT-INET6
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.17 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.17 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface lo0.11
set policy-options policy-statement ISIS-EXPORT term OSPF3-ACCEPT from protocol ospf3
set policy-options policy-statement ISIS-EXPORT term OSPF3-ACCEPT then accept
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet from family inet
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet from protocol static
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet then accept
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 from family inet6
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 from protocol static
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 then accept
set routing-options rib inet6.0 static route ::/0 reject
set routing-options static route 0.0.0.0/0 reject
set routing-options router-id 1.1.1.11
                
VESPASIAN:
 
set  interfaces ae1 unit 18 description TIBERIUS_VESPASION
set  interfaces ae1 unit 18 vlan-id 18
set  interfaces ae1 unit 18 family inet mtu 1500
set  interfaces ae1 unit 18 family inet address 3.0.0.3/29
set  interfaces ae1 unit 18 family iso
set  interfaces ae1 unit 18 family inet6 mtu 1500
set  interfaces ae1 unit 18 family inet6 address 2001:3:1::/64 eui-64
set  interfaces ae1 unit 18 family inet6 address fe80::0018:0000:0000:0013/64
set  interfaces lo0 unit 13 family inet address 1.1.1.13/32
set  interfaces lo0 unit 13 family iso address 49.0002.0000.0000.0013.00
set  interfaces lo0 unit 13 family inet6 address 2001::13/128
set  protocols isis export IS-IS-EXPORT
set  protocols isis lsp-lifetime 3600
set  protocols isis spf-options delay 50
set  protocols isis overload timeout 300
set  protocols isis level 1 wide-metrics-only
set  protocols isis interface ae1.18 level 2 disable
set  protocols isis interface ae1.18 level 1 hello-authentication-key "$9$QvFjn/AB1EhSl8XY4aUkq"
set  protocols isis interface ae1.18 level 1 hello-authentication-type md5
set  protocols isis interface lo0.13
set  policy-options policy-statement IS-IS-EXPORT term STATIC from protocol static
set  policy-options policy-statement IS-IS-EXPORT term STATIC then accept
set  routing-options static route 45.0.3.0/24 reject
set  routing-options static route 45.0.2.0/24 reject
set  routing-options static route 45.0.1.0/24 reject
set  routing-options static route 45.0.0.0/24 reject
                
GAIUS:
 
set apply-groups SA
set interfaces xe-0/3/0 unit 7 description AUGUSTUS
set interfaces xe-0/3/0 unit 7 vlan-id 7
set interfaces xe-0/3/0 unit 7 family inet mtu 1500
set interfaces xe-0/3/0 unit 7 family inet address 2.0.0.25/30
set interfaces xe-0/3/0 unit 7 family iso
set interfaces xe-0/3/0 unit 7 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 7 family inet6 address 2001:2:25::/64 eui-64
set interfaces xe-0/3/0 unit 7 family inet6 address fe80::0007:0000:0000:0003/64
set interfaces xe-0/3/0 unit 8 description COMMODUS
set interfaces xe-0/3/0 unit 8 vlan-id 8
set interfaces xe-0/3/0 unit 8 family inet mtu 1500
set interfaces xe-0/3/0 unit 8 family inet address 2.0.0.29/30
set interfaces xe-0/3/0 unit 8 family iso
set interfaces xe-0/3/0 unit 8 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 8 family inet6 address 2001:2:29::/64 eui-64
set interfaces xe-0/3/0 unit 8 family inet6 address fe80::0008:0000:0000:0003/64
set interfaces lo0 unit 3 family inet address 1.1.1.3/32
set interfaces lo0 unit 3 family inet6 address 2001::3/128
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/2/0.14 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/3/0.8 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/3/0.7 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.3 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.3 passive
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.8 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.8 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.7 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.7 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface lo0.3
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.7 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.7 ipsec-sa ospfv3
                
COMMODOS:
 
set apply-groups SA
set interfaces xe-0/2/0 unit 8 description GAIUS
set interfaces xe-0/2/0 unit 8 vlan-id 8
set interfaces xe-0/2/0 unit 8 family inet mtu 1500
set interfaces xe-0/2/0 unit 8 family inet address 2.0.0.30/30
set interfaces xe-0/2/0 unit 8 family iso
set interfaces xe-0/2/0 unit 8 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 8 family inet6 address 2001:2:29::/64 eui-64
set interfaces xe-0/2/0 unit 8 family inet6 address fe80::1111:1111:1111:1111/64
set interfaces xe-0/2/0 unit 14 description CALIGULA
set interfaces xe-0/2/0 unit 14 vlan-id 14
set interfaces xe-0/2/0 unit 14 family inet mtu 1500
set interfaces xe-0/2/0 unit 14 family inet address 2.0.0.54/30
set interfaces xe-0/2/0 unit 14 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 14 family inet6 address 2001:2:53::54/64
set interfaces xe-0/2/0 unit 14 family inet6 address fe80::2222:2222:2222:2222/64
set interfaces lo0 unit 4 family inet address 1.1.1.4/32
set interfaces lo0 unit 4 family inet6 address 2001::4/128
set protocols ospf3 realm ipv4-unicast export OSPF3-EXPORT-INET
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/2/0.8 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.4 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.4 passive
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/2/0.14 interface-type p2p
set protocols ospf3 export OSPF3-EXPORT-INET6
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.8 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.8 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.14 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.14 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface lo0.4
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet from family inet
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet from protocol static
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet then accept
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 from family inet6
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 from protocol static
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 then accept
set routing-options rib inet6.0 static route 2001:89::/64 reject
set routing-options static route 89.0.0.0/24 reject
set routing-options router-id 1.1.1.4
                
CALIGULA:
 
set apply-groups SA
set interfaces xe-0/3/0 unit 14 description COMMODUS
set interfaces xe-0/3/0 unit 14 vlan-id 14
set interfaces xe-0/3/0 unit 14 family inet mtu 1500
set interfaces xe-0/3/0 unit 14 family inet address 2.0.0.53/30
set interfaces xe-0/3/0 unit 14 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 14 family inet6 address 2001:2:53::53/64
set interfaces xe-0/3/0 unit 14 family inet6 address fe80::0014:0000:0000:0008/64
set interfaces xe-0/3/0 unit 15 description AUGUSTUS
set interfaces xe-0/3/0 unit 15 vlan-id 15
set interfaces xe-0/3/0 unit 15 family inet mtu 1500
set interfaces xe-0/3/0 unit 15 family inet address 2.0.0.57/30
set interfaces xe-0/3/0 unit 15 family iso
set interfaces xe-0/3/0 unit 15 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 15 family inet6 address 2001:2:57::/64 eui-64
set interfaces xe-0/3/0 unit 15 family inet6 address fe80::0015:0000:0000:0008/64
set interfaces xe-0/3/0 unit 16 description SEPTIMUS
set interfaces xe-0/3/0 unit 16 vlan-id 16
set interfaces xe-0/3/0 unit 16 family inet mtu 1500
set interfaces xe-0/3/0 unit 16 family inet address 2.0.0.61/30
set interfaces xe-0/3/0 unit 16 family iso
set interfaces xe-0/3/0 unit 16 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 16 family inet6 address 2001:2:61::/64 eui-64
set interfaces xe-0/3/0 unit 16 family inet6 address fe80:16::2/64
set interfaces lo0 unit 8 family inet address 1.1.1.8/32
set interfaces lo0 unit 8 family inet6 address 2001::8/128
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/3/0.15 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/3/0.14 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.8 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.8 passive
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/3/0.16 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.15 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.15 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.14 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.14 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface lo0.8
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.16 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/3/0.16 ipsec-sa ospfv3
set routing-options router-id 1.1.1.8
                
SEPTIMUS:
 
set apply-groups SA
set interfaces xe-0/2/0 unit 16 description CALIGULA
set interfaces xe-0/2/0 unit 16 vlan-id 16
set interfaces xe-0/2/0 unit 16 family inet mtu 1500
set interfaces xe-0/2/0 unit 16 family inet address 2.0.0.62/30
set interfaces xe-0/2/0 unit 16 family iso
set interfaces xe-0/2/0 unit 16 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 16 family inet6 address 2001:2:61::/64 eui-64
set interfaces xe-0/2/0 unit 16 family inet6 address fe80:16::1/64
set interfaces xe-0/2/0 unit 17 description NERO
set interfaces xe-0/2/0 unit 17 vlan-id 17
set interfaces xe-0/2/0 unit 17 family inet mtu 1500
set interfaces xe-0/2/0 unit 17 family inet address 2.0.0.66/30
set interfaces xe-0/2/0 unit 17 family iso
set interfaces xe-0/2/0 unit 17 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 17 family inet6 address 2001:2:65::/64 eui-64
set interfaces xe-0/2/0 unit 17 family inet6 address fe80:17::1/64
set interfaces lo0 unit 12 family inet address 1.1.1.12/32
set interfaces lo0 unit 12 family inet6 address 2001::12/128
set protocols ospf3 realm ipv4-unicast export OSPF3-EXPORT-INET
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/2/0.17 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.12 interface-type p2p
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.12 passive
set protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface xe-0/2/0.16 interface-type p2p
set protocols ospf3 export OSPF3-EXPORT-INET6
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.17 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.17 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface lo0.12
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.16 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface xe-0/2/0.16 ipsec-sa ospfv3
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet from family inet
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet from protocol static
set policy-options policy-statement OSPF3-EXPORT-INET term ISIS-inet then accept
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 from family inet6
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 from protocol static
set policy-options policy-statement OSPF3-EXPORT-INET6 term ISIS-inet6 then accept
set routing-options rib inet6.0 static route 2001:189::/64 reject
set routing-options static route 189.0.0.0/24 reject
set routing-options router-id 1.1.1.12
                

6-11-2014