OSPFv2 and OSPFv3: a side-by-side configuration.

After being done with the building of an IPv4 OSPF lab, I wanted to delve into OSPFv3 a little more. In this post, I will turn the OSPFv2 configuration into the OSPFv3 equivalent.

The topology for which I will show the side-by-side configuration is the following:



scenario


What I will configure are the different area types, some redistribution, some summarization and more.

I will start out with the backbone area and configure only what is needed for area 0. When I move on to another area, I will also include the configuration that is necessary to connect an area to one of the backbone OSPF routers.

I will not bother showing the interface configuration and the configuration of the security association. I’ll just give one self-explanatory example;

 
set interfaces ge-0/0/0 unit 3029 description R13
set interfaces ge-0/0/0 unit 3029 vlan-id 3029
set interfaces ge-0/0/0 unit 3029 family inet address 16.0.0.5/30
set interfaces ge-0/0/0 unit 3029 family inet6 address 2001:16:5::/64 eui-64

set security ipsec security-association ospfv3 mode transport
set security ipsec security-association ospfv3 manual direction bidirectional protocol ah
set security ipsec security-association ospfv3 manual direction bidirectional spi 256
set security ipsec security-association ospfv3 manual direction bidirectional authentication algorithm hmac-md5-96
set security ipsec security-association ospfv3 manual direction bidirectional authentication key ascii-text "$9$RG/SrKXx-dbYJGPTz6tpY24ZUiPfQz3/uOrKMXdV/9Ap1Rcyl"
                

In case you also happen to have some MX routers at your disposal, to be able to use the security association inside a logical system, you can configure the following;

 
set groups SA security ipsec security-association ospfv3 mode transport
set groups SA security ipsec security-association ospfv3 manual direction bidirectional protocol ah
set groups SA security ipsec security-association ospfv3 manual direction bidirectional spi 256
set groups SA security ipsec security-association ospfv3 manual direction bidirectional authentication algorithm hmac-md5-96
set groups SA security ipsec security-association ospfv3 manual direction bidirectional authentication key ascii-text "$9$9-sgp01SyeKMLdbZDi.TQLX7Vw2ZGjikmz301RSKvmP5Q69tuO"

set logical-systems R11 apply-groups SA
set logical-systems R12 apply-groups SA
etc.
etc.
                



Area 0.0.0.0.

This configuration is about establishing two adjacencies amongst the routers in area 0. In addition to establishing the adjacencies, the R11 router will redistribute a static route into OSPF.



scenario


R11:
 
set protocols ospf export export-into-ospf
set protocols ospf area 0.0.0.0 interface lo0.11 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.11 passive
set protocols ospf area 0.0.0.0 interface ge-0/0/0.3029 interface-type p2p
set protocols ospf area 0.0.0.0 interface ge-0/0/0.3029 authentication md5 111 key "$9$ZAjH.Qzn69t1Rv8X-sY"

set protocols ospf3 export export-into-ospf
set protocols ospf3 area 0.0.0.0 interface lo0.11 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface lo0.11 passive
set protocols ospf3 area 0.0.0.0 interface ge-0/0/0.3029 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface ge-0/0/0.3029 ipsec-sa ospfv3

set routing-options rib inet6.0 static route 2001:212::/64 reject
set routing-options static route 212.0.0.0/24 reject
set routing-options router-id 1.1.1.11

set policy-options policy-statement export-into-ospf term static from protocol static
set policy-options policy-statement export-into-ospf term static then accept
                
R13:
 
set protocols ospf area 0.0.0.0 interface lo0.13 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.13 passive
set protocols ospf area 0.0.0.0 interface ge-0/1/0.3028 interface-type p2p
set protocols ospf area 0.0.0.0 interface ge-0/1/0.3028 authentication simple-password "$9$WahxNVg4JZUiP5Cp0ISy"
set protocols ospf area 0.0.0.0 interface ge-0/1/0.3029 interface-type p2p
set protocols ospf area 0.0.0.0 interface ge-0/1/0.3029 authentication md5 111 key "$9$Y7oJUq.f5Q3ApcreW7N"

set protocols ospf3 area 0.0.0.0 interface lo0.13 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface lo0.13 passive
set protocols ospf3 area 0.0.0.0 interface ge-0/1/0.3028 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface ge-0/1/0.3028 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.0 interface ge-0/1/0.3029 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface ge-0/1/0.3029 ipsec-sa ospfv3

set routing-options router-id 1.1.1.13
                
R12:
 
set protocols ospf area 0.0.0.0 interface lo0.12 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.12 passive
set protocols ospf area 0.0.0.0 interface ge-0/0/0.3028 interface-type p2p
set protocols ospf area 0.0.0.0 interface ge-0/0/0.3028 authentication simple-password "$9$vSTLx-Y2oaZD.P/ApBhc"
    
set protocols ospf3 area 0.0.0.0 interface lo0.12 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface lo0.12 passive
set protocols ospf3 area 0.0.0.0 interface ge-0/0/0.3028 interface-type p2p
set protocols ospf3 area 0.0.0.0 interface ge-0/0/0.3028 ipsec-sa ospfv3
    
set routing-options router-id 1.1.1.12
                

To go through the verification of these configuration statements, click here.



Area 0.0.0.1.

In area 0.0.0.1, there is a multiaccess segment. R15 is configured to be the DR and S1 is configured to be the BDR. R15 will have several additional IP addresses configured on its loopback interface. These IP addresses will be summarized into area 0 by R12. Because of the summarization of these addresses, I have included the loopback configuration on R15 as well.



scenario


R12:
 
set protocols ospf area 0.0.0.1 area-range 80.0.0.0/22
set protocols ospf area 0.0.0.1 interface ge-0/0/0.3031 interface-type p2p
set protocols ospf area 0.0.0.1 interface ge-0/0/0.3031 authentication md5 1 key "$9$eqqWL7wsg4aGk.n9A0RE"   
    
set protocols ospf3 area 0.0.0.1 area-range 2001:80:0::/46
set protocols ospf3 area 0.0.0.1 interface ge-0/0/0.3031 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface ge-0/0/0.3031 ipsec-sa ospfv3
                
R14:
 
set routing-options router-id 1.1.1.14

set protocols ospf area 0.0.0.1 interface lo0.14  interface-type p2p
set protocols ospf area 0.0.0.1 interface lo0.14  passive
set protocols ospf area 0.0.0.1 interface ge-0/1/0.3032 interface-type p2p
set protocols ospf area 0.0.0.1 interface ge-0/1/0.3031 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.1 interface ge-0/1/0.3032 interface-type p2p
set protocols ospf area 0.0.0.1 interface ge-0/1/0.3032 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"

set protocols ospf3 area 0.0.0.1 interface lo0.14 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface lo0.14 passive
set protocols ospf3 area 0.0.0.1 interface ge-0/1/0.3031 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface ge-0/1/0.3031 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.1 interface ge-0/1/0.3032 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface ge-0/1/0.3032 ipsec-sa ospfv3
                
R15:
 
set routing-options router-id 1.1.1.15

set protocols ospf area 0.0.0.1 interface ge-0/0/0.3032 interface-type p2p
set protocols ospf area 0.0.0.1 interface ge-0/0/0.3032 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.1 interface lo0.15 interface-type p2p
set protocols ospf area 0.0.0.1 interface lo0.15 passive
set protocols ospf area 0.0.0.1 interface xe-0/3/0.2000 priority 200
set protocols ospf area 0.0.0.1 interface xe-0/3/0.2000 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"

set protocols ospf3 area 0.0.0.1 interface lo0.15 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface lo0.15 passive
set protocols ospf3 area 0.0.0.1 interface ge-0/0/0.3032 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface ge-0/0/0.3032 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.1 interface xe-0/3/0.2000 priority 200
set protocols ospf3 area 0.0.0.1 interface xe-0/3/0.2000 ipsec-sa ospfv3

set interfaces lo0 unit 15 family inet address 1.1.1.15/32
set interfaces lo0 unit 15 family inet address 80.0.0.1/24
set interfaces lo0 unit 15 family inet address 80.0.2.1/24
set interfaces lo0 unit 15 family inet address 80.0.3.1/24
set interfaces lo0 unit 15 family inet address 80.0.1.1/32
set interfaces lo0 unit 15 family inet6 address 2001::15/128
set interfaces lo0 unit 15 family inet6 address 2001:80:0::1/64
set interfaces lo0 unit 15 family inet6 address 2001:80:1::1/64
set interfaces lo0 unit 15 family inet6 address 2001:80:2::1/64
set interfaces lo0 unit 15 family inet6 address 2001:80:3::1/64
                
R6:
 
set routing-options router-id 1.1.1.6

set protocols ospf area 0.0.0.1 interface ge-1/1/3.2000 priority 0
set protocols ospf area 0.0.0.1 interface ge-1/1/3.2000 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.1 interface lo0.6 interface-type p2p
set protocols ospf area 0.0.0.1 interface lo0.6 passive

set protocols ospf3 area 0.0.0.1 interface ge-1/1/3.2000 priority 0
set protocols ospf3 area 0.0.0.1 interface ge-1/1/3.2000 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.1 interface lo0.6 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface lo0.6 passive
                
S1
 
set routing-options router-id 145.0.0.1

set protocols ospf area 0.0.0.1 interface irb.2000 priority 175
set protocols ospf area 0.0.0.1 interface irb.2000 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.1 interface lo0.10000 interface-type p2p
set protocols ospf area 0.0.0.1 interface lo0.10000 passive

set protocols ospf3 area 0.0.0.1 interface irb.2000 priority 175
set protocols ospf3 area 0.0.0.1 interface irb.2000 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.1 interface lo0.10000 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface lo0.10000 passive
                
45_1:
 
set routing-options router-id 45.0.0.1

set protocols ospf area 0.0.0.1 interface vlan.2000 priority 0
set protocols ospf area 0.0.0.1 interface vlan.2000 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.1 interface lo0.2000 interface-type p2p
set protocols ospf area 0.0.0.1 interface lo0.2000 passive

set protocols ospf3 area 0.0.0.1 interface vlan.2000 priority 0
set protocols ospf3 area 0.0.0.1 interface vlan.2000 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.1 interface lo0.2000 interface-type p2p
set protocols ospf3 area 0.0.0.1 interface lo0.2000 passive
                

To go through the verification of these configuration statements, click here.



Area 0.0.200.1.

This is an NSSA area. The NSSA router R9 will redistribute several static routes into the backbone area. The backbone router, R12, will summarize these prefixes. R12 will be configured to inject a default route into the NSSA area and to not send any Summary-LSAs into the area.



scenario


R9:
 
set routing-options router-id 1.1.1.9

set protocols ospf export OSPF-STATIC
set protocols ospf area 0.0.200.1 nssa
set protocols ospf area 0.0.200.1 interface lo0.9 interface-type p2p
set protocols ospf area 0.0.200.1 interface lo0.9 passive
set protocols ospf area 0.0.200.1 interface xe-0/0/3.31 interface-type p2p
set protocols ospf area 0.0.200.1 interface xe-0/0/3.31 authentication md5 111 key "$9$ZAjH.Qzn69t1Rv8X-sY"

set protocols ospf3 export OSPF3-STATIC
set protocols ospf3 area 0.0.200.1 nssa
set protocols ospf3 area 0.0.200.1 interface lo0.9 interface-type p2p
set protocols ospf3 area 0.0.200.1 interface xe-0/0/3.31 interface-type p2p
set protocols ospf3 area 0.0.200.1 interface xe-0/0/3.31 ipsec-sa ospfv3

set policy-options policy-statement OSPF-STATIC term static from protocol static
set policy-options policy-statement OSPF-STATIC term static then accept

set policy-options policy-statement OSPF3-STATIC term static from family inet6
set policy-options policy-statement OSPF3-STATIC term static from protocol static
set policy-options policy-statement OSPF3-STATIC term static then accept

set routing-options rib inet6.0 static route 2001:56:0::/46 reject
set routing-options rib inet6.0 static route 2001:55:1::/64 reject
set routing-options rib inet6.0 static route 2001:55:2::/64 reject
set routing-options rib inet6.0 static route 2001:55:3::/64 reject
set routing-options rib inet6.0 static route 2001:55:0::/64 reject

set routing-options static route 56.0.0.0/8 reject
set routing-options static route 55.0.0.0/24 reject
set routing-options static route 55.0.1.0/24 reject
set routing-options static route 55.0.2.0/24 reject
                
R12:
 
set protocols ospf area 0.0.200.1 nssa default-lsa default-metric 20
set protocols ospf area 0.0.200.1 nssa no-summaries
set protocols ospf area 0.0.200.1 nssa area-range 55.0.0.0/16
set protocols ospf area 0.0.200.1 interface xe-0/3/1.31 interface-type p2p
set protocols ospf area 0.0.200.1 interface xe-0/3/1.31 authentication md5 111 key "$9$ZAjH.Qzn69t1Rv8X-sY"

set protocols ospf3 area 0.0.200.1 nssa default-lsa default-metric 20
set protocols ospf3 area 0.0.200.1 nssa no-summaries
set protocols ospf3 area 0.0.200.1 nssa area-range 2001:55:0::/46
set protocols ospf3 area 0.0.200.1 interface xe-0/3/1.31 interface-type p2p
set protocols ospf3 area 0.0.200.1 interface xe-0/3/1.31 ipsec-sa ospfv3
                

To go through the verification of these configuration statements, click here.



Area 0.0.0.250.



scenario


This is a totally stubby area deprived of Summary-LSAs and given a default route by R11.

R8:
 
set routing-options router-id 1.1.1.8

set protocols ospf area 0.0.0.250 stub
set protocols ospf area 0.0.0.250 interface lo0.8 interface-type p2p
set protocols ospf area 0.0.0.250 interface lo0.8 passive
set protocols ospf area 0.0.0.250 interface xe-0/0/3.30 interface-type p2p
set protocols ospf area 0.0.0.250 interface xe-0/0/3.30 authentication md5 111 key "$9$ZAjH.Qzn69t1Rv8X-sY"

set protocols ospf3 area 0.0.0.250 stub
set protocols ospf3 area 0.0.0.250 interface lo0.8 interface-type p2p
set protocols ospf3 area 0.0.0.250 interface lo0.8 passive
set protocols ospf3 area 0.0.0.250 interface xe-0/0/3.30 interface-type p2p
set protocols ospf3 area 0.0.0.250 interface xe-0/0/3.30 ipsec-sa ospfv3
                
R11:
 
set protocols ospf area 0.0.0.250 stub default-metric 20
set protocols ospf area 0.0.0.250 stub no-summaries
set protocols ospf area 0.0.0.250 interface xe-0/3/1.30 interface-type p2p
set protocols ospf area 0.0.0.250 interface xe-0/3/1.30 authentication md5 111 key "$9$ZAjH.Qzn69t1Rv8X-sY"

set protocols ospf3 area 0.0.0.250 stub default-metric 20
set protocols ospf3 area 0.0.0.250 stub no-summaries
set protocols ospf3 area 0.0.0.250 interface xe-0/3/1.30 interface-type p2p
set protocols ospf3 area 0.0.0.250 interface xe-0/3/1.30 ipsec-sa ospfv3
                

To go through the verification of these configuration statements, click here.



Area 0.0.0.50.



scenario


There are two things happening in this area on R4. First, a static route is being redistributed into OSPF. Second, area 0.0.0.50 is in between area 0.0.0.150 and the backbone area. In order to connect area 0.0.0.150 to the backbone area, a virtual-link is configured on R4. The other end of the virtual-link is configured on R11.

R11:
 
set protocols ospf area 0.0.0.0 virtual-link neighbor-id 1.1.1.4 transit-area 0.0.0.50 hello-interval 1
set protocols ospf area 0.0.0.0 virtual-link neighbor-id 1.1.1.4 transit-area 0.0.0.50 dead-interval 3
set protocols ospf area 0.0.0.0 virtual-link neighbor-id 1.1.1.4 transit-area 0.0.0.50 authentication md5 14 key "$9$OM2sRhyMWXxNVgokmfz/9"

set protocols ospf area 0.0.0.50 interface ge-0/1/0.3033 interface-type p2p
set protocols ospf area 0.0.0.50 interface ge-0/1/0.3033 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"

set protocols ospf3 area 0.0.0.0 virtual-link neighbor-id 1.1.1.4 transit-area 0.0.0.50 hello-interval 1
set protocols ospf3 area 0.0.0.0 virtual-link neighbor-id 1.1.1.4 transit-area 0.0.0.50 dead-interval 3
set protocols ospf3 area 0.0.0.0 virtual-link neighbor-id 1.1.1.4 transit-area 0.0.0.50 ipsec-sa ospfv3

set protocols ospf3 area 0.0.0.50 interface ge-0/1/0.3033 interface-type p2p
set protocols ospf3 area 0.0.0.50 interface ge-0/1/0.3033 ipsec-sa ospfv3
                
R16:
 
set protocols ospf area 0.0.0.50 interface ge-0/0/0.3033 interface-type p2p
set protocols ospf area 0.0.0.50 interface ge-0/0/0.3033 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.50 interface lo0.16 interface-type p2p
set protocols ospf area 0.0.0.50 interface lo0.16 passive
set protocols ospf area 0.0.0.50 interface xe-0/2/0.1 interface-type p2p
set protocols ospf area 0.0.0.50 interface xe-0/2/0.1 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
    
set protocols ospf3 area 0.0.0.50 interface ge-0/0/0.3033 interface-type p2p
set protocols ospf3 area 0.0.0.50 interface ge-0/0/0.3033 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.50 interface lo0.16 interface-type p2p
set protocols ospf3 area 0.0.0.50 interface lo0.16 passive
set protocols ospf3 area 0.0.0.50 interface xe-0/2/0.1 interface-type p2p
set protocols ospf3 area 0.0.0.50 interface xe-0/2/0.1 ipsec-sa ospfv3

set routing-options router-id 1.1.1.16
                
R4:
 
set protocols ospf export OSPF
set protocols ospf area 0.0.0.50 interface xe-0/0/2.1 interface-type p2p
set protocols ospf area 0.0.0.50 interface xe-0/0/2.1 metric 10
set protocols ospf area 0.0.0.50 interface xe-0/0/2.1 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.50 interface lo0.4 interface-type p2p
set protocols ospf area 0.0.0.50 interface lo0.4 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.150 interface ge-1/0/3.59 interface-type p2p
set protocols ospf area 0.0.0.150 interface ge-1/0/3.59 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.0 virtual-link neighbor-id 1.1.1.11 transit-area 0.0.0.50 hello-interval 1
set protocols ospf area 0.0.0.0 virtual-link neighbor-id 1.1.1.11 transit-area 0.0.0.50 dead-interval 3
set protocols ospf area 0.0.0.0 virtual-link neighbor-id 1.1.1.11 transit-area 0.0.0.50 authentication md5 14 key "$9$QY6zn/AB1EhSl8XY4aUkq"

set protocols ospf3 export OSPF3
set protocols ospf3 area 0.0.0.50 interface xe-0/0/2.1 interface-type p2p
set protocols ospf3 area 0.0.0.50 interface xe-0/0/2.1 metric 10
set protocols ospf3 area 0.0.0.50 interface xe-0/0/2.1 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.50 interface lo0.4 interface-type p2p
set protocols ospf3 area 0.0.0.50 interface lo0.4 passive
set protocols ospf3 area 0.0.0.0 virtual-link neighbor-id 1.1.1.11 transit-area 0.0.0.50 hello-interval 1
set protocols ospf3 area 0.0.0.0 virtual-link neighbor-id 1.1.1.11 transit-area 0.0.0.50 dead-interval 3
set protocols ospf3 area 0.0.0.0 virtual-link neighbor-id 1.1.1.11 transit-area 0.0.0.50 ipsec-sa ospfv3

set policy-options policy-statement OSPF from protocol static
set policy-options policy-statement OSPF then accept
set policy-options policy-statement OSPF3 from family inet6
set policy-options policy-statement OSPF3 from protocol static
set policy-options policy-statement OSPF3 then accept

set routing-options rib inet6.0 static route 2001:4::/64 reject
set routing-options static route 4.0.0.0/24 reject
set routing-options router-id 1.1.1.4
                

To go through the verification of these configuration statements, click here.



Area 0.0.0.150.



scenario


This is the last area. There is 1 router in here, R3. This router is doing BGP and it is summarizing the learned prefixes into OSPF by means of an aggregate route.

R4:
 
set protocols ospf area 0.0.0.150 interface ge-1/0/3.59 interface-type p2p
set protocols ospf area 0.0.0.150 interface ge-1/0/3.59 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
    
set protocols ospf3 area 0.0.0.150 interface ge-1/0/3.59 interface-type p2p
set protocols ospf3 area 0.0.0.150 interface ge-1/0/3.59 ipsec-sa ospfv3
                
R3:
 
set protocols bgp group EXTERNAL neighbor 2.0.0.42 peer-as 2
set protocols bgp group EXTERNAL-V6 neighbor 2001:2:41::5 peer-as 2

set protocols ospf spf-options delay 400
set protocols ospf spf-options holddown 9000
set protocols ospf spf-options rapid-runs 10

set protocols ospf export EXPORT-AGGREGATE
set protocols ospf area 0.0.0.150 interface ge-1/1/3.59 interface-type p2p
set protocols ospf area 0.0.0.150 interface ge-1/1/3.59 authentication md5 1 key "$9$cuvlKWN-bwY4UjTFnC0O"
set protocols ospf area 0.0.0.150 interface lo0.3 interface-type p2p
set protocols ospf area 0.0.0.150 interface lo0.3 passive

set protocols ospf3 spf-options delay 400
set protocols ospf3 spf-options holddown 9000
set protocols ospf3 spf-options rapid-runs 2

set protocols ospf3 export EXPORT-AGGREGATE
set protocols ospf3 area 0.0.0.150 interface ge-1/1/3.59 interface-type p2p
set protocols ospf3 area 0.0.0.150 interface ge-1/1/3.59 ipsec-sa ospfv3
set protocols ospf3 area 0.0.0.150 interface lo0.3 interface-type p2p
set protocols ospf3 area 0.0.0.150 interface lo0.3 passive

set policy-options policy-statement EXPORT-AGGREGATE from protocol aggregate
set policy-options policy-statement EXPORT-AGGREGATE then accept

set routing-options rib inet6.0 aggregate route 2001:201:0::/46
set routing-options aggregate route 201.0.0.0/22
set routing-options router-id 1.1.1.3
set routing-options autonomous-system 1
                

To go through the verification of these configuration statements, click here.

That’s all.

16-10-2014