EVPN on Juniper MX: interconnecting Data Centers on layer 2 and 3 configuration



MX480:
set chassis network-services enhanced-ip

set interfaces ge-0/1/0 flexible-vlan-tagging
set interfaces ge-0/1/0 encapsulation flexible-ethernet-services
set interfaces ge-0/1/0 unit 50 description CPE_EVPN
set interfaces ge-0/1/0 unit 50 encapsulation vlan-bridge
set interfaces ge-0/1/0 unit 50 vlan-id 50
set interfaces ge-0/1/0 unit 50 family bridge

set interfaces irb unit 50 description EVPN-Gateway-datacenter-2
set interfaces irb unit 50 family inet address 8.0.0.1/24
set interfaces irb unit 50 mac 00:00:00:00:00:33

set routing-options autonomous-system 1
set routing-options forwarding-table chained-composite-next-hop ingress evpn

set protocols bgp local-address 1.1.1.21
set protocols bgp out-delay 2
set protocols bgp log-updown
set protocols bgp group rr type internal
set protocols bgp group rr family inet unicast
set protocols bgp group rr family evpn signaling
set protocols bgp group rr authentication-key "$9$CVAyuOIyrKvWXVwGjHmQz"
set protocols bgp group rr export bgp-export
set protocols bgp group rr peer-as 1
set protocols bgp group rr neighbor 1.1.1.1 description Aurelius_rr

set routing-instances evpn_vlan-based instance-type evpn
set routing-instances evpn_vlan-based vlan-id 50
set routing-instances evpn_vlan-based interface ge-0/1/0.50
set routing-instances evpn_vlan-based routing-interface irb.50
set routing-instances evpn_vlan-based route-distinguisher 3:3
set routing-instances evpn_vlan-based vrf-target target:3:3
set routing-instances evpn_vlan-based protocols evpn default-gateway do-not-advertise
                
set policy-options policy-statement bgp-export term local-evpn-routes from protocol evpn
set policy-options policy-statement bgp-export term local-evpn-routes then accept

set policy-options policy-statement bgp-export term evpn from family evpn
set policy-options policy-statement bgp-export term evpn then accept
MX104:
set chassis network-services enhanced-ip

set interfaces xe-2/0/0 flexible-vlan-tagging
set interfaces xe-2/0/0 encapsulation flexible-ethernet-services
set interfaces xe-2/0/0 unit 50 description CPE_EVPN
set interfaces xe-2/0/0 unit 50 encapsulation vlan-bridge
set interfaces xe-2/0/0 unit 50 vlan-id 50
set interfaces xe-2/0/0 unit 50 family bridge

set interfaces irb unit 50 description EVPN-Gateway-datacenter-2
set interfaces irb unit 50 family inet address 8.0.0.1/24
set interfaces irb unit 50 mac 00:00:00:00:00:33

set routing-options autonomous-system 1
set routing-options forwarding-table chained-composite-next-hop ingress evpn

set protocols bgp local-address 1.1.1.20
set protocols bgp out-delay 2
set protocols bgp log-updown
set protocols bgp group rr type internal
set protocols bgp group rr family inet unicast
set protocols bgp group rr family evpn signaling
set protocols bgp group rr authentication-key "$9$CVAyuOIyrKvWXVwGjHmQz"
set protocols bgp group rr export bgp-export
set protocols bgp group rr peer-as 1
set protocols bgp group rr neighbor 1.1.1.1 description Aurelius_rr

set routing-instances evpn_vlan-based instance-type evpn
set routing-instances evpn_vlan-based vlan-id 50
set routing-instances evpn_vlan-based interface xe-2/0/0.50
set routing-instances evpn_vlan-based routing-interface irb.50
set routing-instances evpn_vlan-based route-distinguisher 3:3
set routing-instances evpn_vlan-based vrf-target target:3:3
set routing-instances evpn_vlan-based protocols evpn default-gateway do-not-advertise
                
set policy-options policy-statement bgp-export term local-evpn-routes from protocol evpn
set policy-options policy-statement bgp-export term local-evpn-routes then accept

set policy-options policy-statement bgp-export term evpn from family evpn
set policy-options policy-statement bgp-export term evpn then accept

RSVP signaled LSPs were took care of the label distribution in this lab. The accompanying article can be found here.

27-7-2015