JNCIP-SP: Another Area, redistribution and summarization.

In this part, several things are going to happen. The goal of this episode is to end up with the following;



scenario


To get there, we will extend the lab with two more routers situated in area 0.0.0.1.

After the addition of R14 and R15, we will configure R15 to advertise additional prefixes. Some of these prefixes will be additional loopback IP addresses advertised as Router-LSA. Another prefix will be a static route, advertised as an External-LSA.

Since redistributing statics will turn an OSPF router into an ASBR, we will dive into that concept as well.

We will finish things of with some summarization on the ABR R12.



Expanding the lab with area 0.0.0.1 and two routers, R14 and R15.

To expand the lab with an additional area and two routers, I’ve added the following configuration:

R12:
 
set protocols ospf area 0.0.0.1 interface ge-0/0/0.3031 interface-type p2p
set protocols ospf area 0.0.0.1 interface ge-0/0/0.3031 authentication md5 1 key GEHEIM
                
R14:
 
set routing-options router-id 1.1.1.14
set protocols ospf area 0.0.0.1 interface 16.0.0.14 interface-type p2p
set protocols ospf area 0.0.0.1 interface 16.0.0.14 authentication md5 1 key GEHEIM
set protocols ospf area 0.0.0.1 interface 1.1.1.14 interface-type p2p
set protocols ospf area 0.0.0.1 interface 1.1.1.14 passive
set protocols ospf area 0.0.0.1 interface 16.0.0.18 interface-type p2p
set protocols ospf area 0.0.0.1 interface 16.0.0.18 authentication md5 1 key GEHEIM
                
R15:
 
set routing-options router-id 1.1.1.15
set protocols ospf area 0.0.0.1 interface ge-0/0/0.3032 interface-type p2p
set protocols ospf area 0.0.0.1 interface ge-0/0/0.3032 authentication md5 1 key GEHEIM
set protocols ospf area 0.0.0.1 interface lo0.15 interface-type p2p
set protocols ospf area 0.0.0.1 interface lo0.15 passive
                

The above configuration should seem familiar. The only real difference is that in this case, the interfaces are configured under area 0.0.0.1. Another minor difference is that on R14, instead of referencing the interface, I referenced the IP address. Functionality wise, this has no impact.

Let’s check R14 to see if the neighbors were formed:



scenario


Also note that due to this configuration, R12 is now connected to different areas. This means R12 has become an Area Border router;



scenario


Besides connecting different areas to the backbone area, the ABR is responsible for transmitting information between these two areas. An ABR always maintains a database for each area it is connected to. In our case, this means R12 will have a database for area 0.0.0.0 and a separate database for area 0.0.0.1.



scenario


A thing to notice is that some LSAs are changed by the ABR. Router LSAs are flooded only throughout the area they are originated in. In the picture above, I’ve tried to clarify this. R12 is shown with two different LSDBs. On the left side, the area 0.0.0.0 LSDB contains 1.1.1.11 as a router LSA. R12 will not flood this router LSA into area 0.0.0.1. Instead, this LSA is translated into a summary LSA. This summary LSA is generated by the ABR and consequently sent into area 0.0.0.1.



scenario


The output taken on R12 shows that the router LSA generated by R11 and received in area 0.0.0.0 is generated by R12 itself for area 0.0.0.1.

A closer look into this process reveals that the router LSA is not just regenerated. The router LSA contains a set of links. The summary LSA does not. When R12 translates the router LSA sent by R11, it will actually generate a summary-LSA for each prefix contained in the router LSA. Let’s have a look at all the summary-LSAs currently generated by R12 and sent into area 0.0.0.1:



scenario


The printout above is showing that topology information carried inside the router-LSAs in area 0.0.0.0 is stripped when R12 generates the summary-LSA for area 0.0.0.1. Via summary-LSAs, an ABR only advertises the prefixes and the metrics that belongs to those prefixes.



Redistributing a static on R15.

To redistribute a static route, we need a static route and an applied export policy. This can be configured in the following manner:

R15:
 
set routing-options static route 90.0.0.0/24 reject
set policy-options policy-statement OSPF term inject-static from protocol static
set policy-options policy-statement OSPF term inject-static then accept
set protocols ospf export OSPF
                

After applying the configuration, R15 will turn into an ASBR and it will advertise the route as an external LSA with a type 2 metric:



scenario


The External LSA is flooded throughout the AS. The LSA itself is unchanged as it is flooded through the different areas. R12 will not only flood the External LSA into area 0.0.0.0, it also generate a type 4 Summary-LSA. This type 4 LSA is the ASBR-Summary-LSA, which is nothing more than a description to the ASBR router in another area.



scenario


The printout on R11 above shows us that the External LSA was received unaltered as it was generated by R15. The ASBR-Summary-LSA was generated by R12.

The ABR is not just there to change Router LSAs to Summary LSAs, or to generate ASBR-summary-LSAs. An ABR can be used to perform route summarization. This can reduce the size of the LSDB and hide routing-instability (if there is any of course).



Summarization.

To finish things up, let’s configure route summarization on R12. Before we can summarize anything, we will need several prefixes that we can actually summarize. To that end, let’s first configure several extra IP addresses as loopback IP address on R15:

R15:
 
set interfaces lo0 unit 15 family inet address 80.0.0.1/24
set interfaces lo0 unit 15 family inet address 80.0.1.1/24
set interfaces lo0 unit 15 family inet address 80.0.2.1/24
set interfaces lo0 unit 15 family inet address 80.0.3.1/24
                

Since we configured the loopback interface in the OSPF hierarchy, all the IP address configured on the loopback interface will be advertised as a link in the Router-LSA:



scenario


These router LSAs are flooded throughout the area but no further. Without summarization, R12 would advertise 4 Summary LSAs for these loopback IP addresses into area 0.0.0.0:



scenario


Upon using summarization, we can turn 4 prefixes into 1 and we can hide routing instability.

To summarize a prefix range on Junos, you have to use the ‘area-range’ command and specify the summarized prefix. Junos will suppress the advertisement of prefixes that fall in the specified range. Another thing is that the command is configured for the area where the prefixes you want to summarize are coming from.

In our case, we want to summarize the prefixes 80.0.0.0/24 up to 80.0.3.0/24, coming from area 0.0.0.1 into 80.0.0.0/22. This would require the following command;

 
set protocols ospf area 0.0.0.1 area-range 80.0.0.0/22
                

The end result will be the following;



scenario


On R12 we can see that only 1 prefix is advertised. In the OSPF database on R11, we can see that there is a Summary LSA present for prefix 80.0.0.0/22.



scenario


22-9-2014