ISIS, BGP and ip-vpn.



The IS-IS part.

Routers 1 through 8 form an IS-IS network. The entire configuration is pretty basic. The IS-IS network is a single area containing only level 2 routers. Authentication is configured under the [protocols isis level] configuration hierarchy.

Links are configured as point-to-point links, BFD is enabled between the routers and the Link-State PDU lifetime is set to 3600 seconds.

There is an overload timeout set, making the router very unattractive for transit traffic at startup. ISIS will run SPF 50ms after a change. The only spf option that is configured is the delay, so the rapid runs are left to the default of 3 and the hold down timer is left to the default of 200ms.



The BGP part.

The routers running ISIS form a BGP confederation. The global AS (64512) is divided into two sub-autonomous systems. These are AS 65001 and AS 65002.

Each sub-AS has a route-reflector cluster. In AS 65001, Aurelius and Trajan form a route-reflector cluster. In AS 65002, Gaius and Commodus form a route-reflector cluster.

Routing information between the sub-AS’s is exchanged via the BGP group CBGP. This group is configured on all route reflectors. The group is configured with multihop allowing for loopback based BGP sessions.

All BGP routers are configured with the ‘inet-vpn’ and the ‘inet6-vpn’ unicast group, enabling these types of VPNs all through AS64512.



The MPLS part:

The LSP’s are set up using RSVP. Every LSP has an active standby path configured.

Another thing configured is ‘ipv6-tunneling’. This will allow IPv6 routes to be resolved over the MPLS network, enabling 6PE.

R5 through R8 have an LSP configured towards each other to be able to label-switch ip-vpn traffic from every PE to every other PE. The PE routers do not need an LSP towards the route-reflectors since there are no routing-instances configured on those routers.

The route-reflectors, however, do need an LSP to every PE. This is because in order to readvertise routing information for an ip-vpn, the route reflector has to be able to resolve the next-hop itself as well. By configuring an LSP towards all PE’s, the route reflectors can resolve all PE’s in the inet.3 (inet6.3 for 6pe) routing table as a next-hop .

scenario
Enlarge.

AURELIUS:
 
set interfaces xe-0/2/0 unit 2 description REMUS
set interfaces xe-0/2/0 unit 2 vlan-id 2
set interfaces xe-0/2/0 unit 2 family inet mtu 1500
set interfaces xe-0/2/0 unit 2 family inet address 2.0.0.6/30
set interfaces xe-0/2/0 unit 2 family iso
set interfaces xe-0/2/0 unit 2 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 2 family inet6 address 2001:2:5::/64 eui-64
set interfaces xe-0/2/0 unit 2 family inet6 address fe80::0002:0000:0000:0001/64
set interfaces xe-0/2/0 unit 2 family mpls
set interfaces xe-0/3/0 unit 4 description TRAJAN
set interfaces xe-0/3/0 unit 4 vlan-id 4
set interfaces xe-0/3/0 unit 4 family inet mtu 1500
set interfaces xe-0/3/0 unit 4 family inet address 2.0.0.13/30
set interfaces xe-0/3/0 unit 4 family iso
set interfaces xe-0/3/0 unit 4 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 4 family inet6 address 2001:2:13::/64 eui-64
set interfaces xe-0/3/0 unit 4 family inet6 address fe80::0004:0000:0000:0001/64
set interfaces xe-0/3/0 unit 4 family mpls
set interfaces lo0 unit 1 family inet address 1.1.1.1/32
set interfaces lo0 unit 1 family iso address 49.0001.0000.0000.0001.00
set interfaces lo0 unit 1 family inet6 address 2001::1/128
set protocols rsvp interface xe-0/3/0.4
set protocols rsvp interface xe-0/2/0.2
set protocols mpls ipv6-tunneling
set protocols mpls label-switched-path R1-R5 to 1.1.1.5
set protocols mpls label-switched-path R1-R6 to 1.1.1.6
set protocols mpls label-switched-path R1-R7 to 1.1.1.7
set protocols mpls label-switched-path R1-R8 to 1.1.1.8
set protocols mpls interface xe-0/3/0.4
set protocols mpls interface xe-0/2/0.2
set protocols bgp group AS-65001 type internal
set protocols bgp group AS-65001 local-address 1.1.1.1
set protocols bgp group AS-65001 family inet-vpn unicast
set protocols bgp group AS-65001 family inet6-vpn unicast
set protocols bgp group AS-65001 authentication-key "$9$uxje1RcKv8Lx-YgiqmTn6"
set protocols bgp group AS-65001 cluster 1.1.1.1
set protocols bgp group AS-65001 neighbor 1.1.1.2
set protocols bgp group AS-65001 neighbor 1.1.1.5
set protocols bgp group AS-65001 neighbor 1.1.1.6
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$KMV8XNsY4oJUqm6CtOEh"
set protocols isis level 2 authentication-type md5
set protocols isis interface xe-0/2/0.2 point-to-point
set protocols isis interface xe-0/2/0.2 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.2 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.2 level 1 disable
set protocols isis interface xe-0/3/0.4 point-to-point
set protocols isis interface xe-0/3/0.4 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.4 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.4 level 1 disable
set protocols isis interface lo0.1 passive
set routing-options autonomous-system 65001
set routing-options confederation 64512
set routing-options confederation members 65001
set routing-options confederation members 65002
                
TRAJAN:
 
set interfaces xe-0/2/0 unit 4 description AURELIUS
set interfaces xe-0/2/0 unit 4 vlan-id 4
set interfaces xe-0/2/0 unit 4 family inet mtu 1500
set interfaces xe-0/2/0 unit 4 family inet address 2.0.0.14/30
set interfaces xe-0/2/0 unit 4 family iso
set interfaces xe-0/2/0 unit 4 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 4 family inet6 address 2001:2:13::/64 eui-64
set interfaces xe-0/2/0 unit 4 family inet6 address fe80::0004:0000:0000:0002/64
set interfaces xe-0/2/0 unit 4 family mpls
set interfaces xe-0/2/0 unit 5 description ROMULUS
set interfaces xe-0/2/0 unit 5 vlan-id 5
set interfaces xe-0/2/0 unit 5 family inet mtu 1500
set interfaces xe-0/2/0 unit 5 family inet address 2.0.0.18/30
set interfaces xe-0/2/0 unit 5 family iso
set interfaces xe-0/2/0 unit 5 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 5 family inet6 address 2001:2:17::/64 eui-64
set interfaces xe-0/2/0 unit 5 family inet6 address fe80::0005:0000:0000:0002/64
set interfaces xe-0/2/0 unit 5 family mpls
set interfaces xe-0/2/0 unit 6 description GAIUS
set interfaces xe-0/2/0 unit 6 vlan-id 6
set interfaces xe-0/2/0 unit 6 family inet mtu 1500
set interfaces xe-0/2/0 unit 6 family inet address 2.0.0.22/30
set interfaces xe-0/2/0 unit 6 family iso
set interfaces xe-0/2/0 unit 6 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 6 family inet6 address 2001:2:21::/64 eui-64
set interfaces xe-0/2/0 unit 6 family inet6 address fe80::0006:0000:0000:0002/64
set interfaces xe-0/2/0 unit 6 family mpls
set interfaces lo0 unit 2 family inet address 1.1.1.2/32
set interfaces lo0 unit 2 family iso address 49.0001.0000.0000.0002.00
set interfaces lo0 unit 2 family inet6 address 2001::2/128
set protocols rsvp interface xe-0/2/0.4
set protocols rsvp interface xe-0/2/0.5
set protocols rsvp interface xe-0/3/0.6
set protocols mpls ipv6-tunneling
set protocols mpls label-switched-path R2-R5 to 1.1.1.5
set protocols mpls label-switched-path R2-R6 to 1.1.1.6
set protocols mpls label-switched-path R2-R8 to 1.1.1.8
set protocols mpls label-switched-path R2-R7 to 1.1.1.7
set protocols mpls interface xe-0/2/0.4
set protocols mpls interface xe-0/2/0.5
set protocols mpls interface xe-0/2/0.6
set protocols bgp group AS-65001 type internal
set protocols bgp group AS-65001 local-address 1.1.1.2
set protocols bgp group AS-65001 family inet-vpn unicast
set protocols bgp group AS-65001 family inet6-vpn unicast
set protocols bgp group AS-65001 authentication-key "$9$jfqm5n6CApOhSL7-w4o"
set protocols bgp group AS-65001 cluster 1.1.1.1
set protocols bgp group AS-65001 neighbor 1.1.1.1
set protocols bgp group AS-65001 neighbor 1.1.1.5
set protocols bgp group AS-65001 neighbor 1.1.1.6
set protocols bgp group CBGP type external
set protocols bgp group CBGP multihop
set protocols bgp group CBGP local-address 1.1.1.2
set protocols bgp group CBGP family inet-vpn unicast
set protocols bgp group CBGP family inet6-vpn unicast
set protocols bgp group CBGP authentication-key "$9$jfqm5n6CApOhSL7-w4o"
set protocols bgp group CBGP peer-as 65002
set protocols bgp group CBGP neighbor 1.1.1.3
set protocols bgp group CBGP neighbor 1.1.1.4
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$KMV8XNsY4oJUqm6CtOEh"
set protocols isis level 2 authentication-type md5
set protocols isis interface xe-0/2/0.4 point-to-point
set protocols isis interface xe-0/2/0.4 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.4 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.4 level 1 disable
set protocols isis interface xe-0/2/0.5 point-to-point
set protocols isis interface xe-0/2/0.5 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.5 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.5 level 1 disable
set protocols isis interface xe-0/2/0.6 point-to-point
set protocols isis interface xe-0/2/0.6 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.6 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.6 level 1 disable
set protocols isis interface lo0.2 passive
set routing-options autonomous-system 65001
set routing-options confederation 64512
set routing-options confederation members 65001
set routing-options confederation members 65002
                
REMUS:
 
set interfaces xe-0/3/0 unit 1 description ROMULUS
set interfaces xe-0/3/0 unit 1 vlan-id 1
set interfaces xe-0/3/0 unit 1 family inet mtu 1500
set interfaces xe-0/3/0 unit 1 family inet address 2.0.0.1/30
set interfaces xe-0/3/0 unit 1 family iso
set interfaces xe-0/3/0 unit 1 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 1 family inet6 address 2001:2:1::/64 eui-64
set interfaces xe-0/3/0 unit 1 family inet6 address fe80::0001:0000:0000:0004/64
set interfaces xe-0/3/0 unit 1 family mpls
set interfaces xe-0/3/0 unit 2 description AURELIUS
set interfaces xe-0/3/0 unit 2 vlan-id 2
set interfaces xe-0/3/0 unit 2 family inet mtu 1500
set interfaces xe-0/3/0 unit 2 family inet address 2.0.0.5/30
set interfaces xe-0/3/0 unit 2 family iso
set interfaces xe-0/3/0 unit 2 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 2 family inet6 address 2001:2:5::/64 eui-64
set interfaces xe-0/3/0 unit 2 family inet6 address fe80::0002:0000:0000:0004/64
set interfaces xe-0/3/0 unit 2 family mpls
set interfaces xe-0/3/0 unit 3 description TIBERIUS
set interfaces xe-0/3/0 unit 3 vlan-id 3
set interfaces xe-0/3/0 unit 3 family inet mtu 1500
set interfaces xe-0/3/0 unit 3 family inet address 2.0.0.9/30
set interfaces xe-0/3/0 unit 3 family iso
set interfaces xe-0/3/0 unit 3 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 3 family inet6 address fe80::0003:0000:0000:0004/64
set interfaces xe-0/3/0 unit 3 family inet6 address 2001:2:9::5/64
set interfaces lo0 unit 5 family inet address 1.1.1.5/32
set interfaces lo0 unit 5 family iso address 49.0001.0000.0000.0005.00
set interfaces lo0 unit 5 family inet6 address 2001::5/128
set protocols rsvp interface xe-0/3/0.1
set protocols rsvp interface xe-0/3/0.2
set protocols mpls ipv6-tunneling
set protocols mpls label-switched-path R5-R6 to 1.1.1.6
set protocols mpls label-switched-path R5-R6 revert-timer 10
set protocols mpls label-switched-path R5-R6 primary via_R6
set protocols mpls label-switched-path R5-R6 secondary via_R1 standby
set protocols mpls label-switched-path R5-R7 to 1.1.1.7
set protocols mpls label-switched-path R5-R7 revert-timer 20
set protocols mpls label-switched-path R5-R7 primary via_R6
set protocols mpls label-switched-path R5-R7 secondary via_R1 standby
set protocols mpls label-switched-path R5-R8 to 1.1.1.8
set protocols mpls label-switched-path R5-R8 revert-timer 30
set protocols mpls label-switched-path R5-R8 primary via_R6
set protocols mpls label-switched-path R5-R8 secondary via_R1 standby
set protocols mpls path via_R1 1.1.1.1 strict
set protocols mpls path via_R6 1.1.1.6 strict
set protocols mpls interface xe-0/3/0.1
set protocols mpls interface xe-0/3/0.2
set protocols bgp group AS-65001 type internal
set protocols bgp group AS-65001 local-address 1.1.1.5
set protocols bgp group AS-65001 family inet-vpn unicast
set protocols bgp group AS-65001 family inet6-vpn unicast
set protocols bgp group AS-65001 authentication-key "$9$xyxdbYJZDjH.QFuBIceK"
set protocols bgp group AS-65001 export REDIS-STATIC
set protocols bgp group AS-65001 neighbor 1.1.1.1
set protocols bgp group AS-65001 neighbor 1.1.1.2
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$KMV8XNsY4oJUqm6CtOEh"
set protocols isis level 2 authentication-type md5
set protocols isis interface xe-0/3/0.1 point-to-point
set protocols isis interface xe-0/3/0.1 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.1 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.1 level 1 disable
set protocols isis interface xe-0/3/0.2 point-to-point
set protocols isis interface xe-0/3/0.2 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.2 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.2 level 1 disable
set protocols isis interface lo0.5 passive
set policy-options policy-statement BGP-IMPORT term PRIMARY from protocol bgp
set policy-options policy-statement BGP-IMPORT term PRIMARY then local-preference 150
set policy-options policy-statement REDIS-STATIC from protocol static
set policy-options policy-statement REDIS-STATIC then next-hop self
set policy-options policy-statement REDIS-STATIC then accept
set routing-instances IPVPN instance-type vrf
set routing-instances IPVPN interface xe-0/3/0.3
set routing-instances IPVPN route-distinguisher 1:1
set routing-instances IPVPN vrf-target target:1:1
set routing-instances IPVPN vrf-table-label
set routing-instances IPVPN protocols bgp group CPE type external
set routing-instances IPVPN protocols bgp group CPE passive
set routing-instances IPVPN protocols bgp group CPE authentication-key "$9$PQF6puB1RcKMVs2aDj"
set routing-instances IPVPN protocols bgp group CPE peer-as 65500
set routing-instances IPVPN protocols bgp group CPE as-override
set routing-instances IPVPN protocols bgp group CPE neighbor 2.0.0.10 metric-out 75
set routing-instances IPVPN protocols bgp group CPE neighbor 2.0.0.10 import BGP-IMPORT
set routing-instances IPVPN protocols bgp group CPE-V6 type external
set routing-instances IPVPN protocols bgp group CPE-V6 passive
set routing-instances IPVPN protocols bgp group CPE-V6 authentication-key "$9$PQF6puB1RcKMVs2aDj"
set routing-instances IPVPN protocols bgp group CPE-V6 peer-as 65500
set routing-instances IPVPN protocols bgp group CPE-V6 as-override
set routing-instances IPVPN protocols bgp group CPE-V6 neighbor 2001:2:9::9 metric-out 75
set routing-instances IPVPN protocols bgp group CPE-V6 neighbor 2001:2:9::9 import BGP-IMPORT
set routing-options static route 40.0.0.0/8 reject
set routing-options autonomous-system 65001
set routing-options confederation 64512
set routing-options confederation members 65001
set routing-options confederation members 65002
                
ROMULUS:
 
set interfaces xe-0/2/0 unit 1 description REMUS
set interfaces xe-0/2/0 unit 1 vlan-id 1
set interfaces xe-0/2/0 unit 1 family inet mtu 1500
set interfaces xe-0/2/0 unit 1 family inet address 2.0.0.2/30
set interfaces xe-0/2/0 unit 1 family iso
set interfaces xe-0/2/0 unit 1 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 1 family inet6 address 2001:2:1::/64 eui-64
set interfaces xe-0/2/0 unit 1 family inet6 address fe80::0001:0000:0000:0006/64
set interfaces xe-0/2/0 unit 1 family mpls
set interfaces xe-0/2/0 unit 10 description HADRIAN
set interfaces xe-0/2/0 unit 10 vlan-id 10
set interfaces xe-0/2/0 unit 10 family inet mtu 1500
set interfaces xe-0/2/0 unit 10 family inet address 2.0.0.38/30
set interfaces xe-0/2/0 unit 10 family iso
set interfaces xe-0/2/0 unit 10 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 10 family inet6 address fe80::0010:0000:0000:0006/64
set interfaces xe-0/2/0 unit 10 family inet6 address 2001:2:37::6/64
set interfaces xe-0/2/0 unit 13 description AUGUSTUS
set interfaces xe-0/2/0 unit 13 vlan-id 13
set interfaces xe-0/2/0 unit 13 family inet mtu 1500
set interfaces xe-0/2/0 unit 13 family inet address 2.0.0.50/30
set interfaces xe-0/2/0 unit 13 family iso
set interfaces xe-0/2/0 unit 13 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 13 family inet6 address 2001:2:49::/64 eui-64
set interfaces xe-0/2/0 unit 13 family inet6 address fe80::0013:0000:0000:0006/64
set interfaces xe-0/2/0 unit 13 family mpls
set interfaces xe-0/3/0 unit 5 description TRAJAN
set interfaces xe-0/3/0 unit 5 vlan-id 5
set interfaces xe-0/3/0 unit 5 family inet mtu 1500
set interfaces xe-0/3/0 unit 5 family inet address 2.0.0.17/30
set interfaces xe-0/3/0 unit 5 family iso
set interfaces xe-0/3/0 unit 5 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 5 family inet6 address 2001:2:17::/64 eui-64
set interfaces xe-0/3/0 unit 5 family inet6 address fe80::0005:0000:0000:0006/64
set interfaces xe-0/3/0 unit 5 family mpls
set interfaces lo0 unit 6 family inet address 1.1.1.6/32
set interfaces lo0 unit 6 family iso address 49.0001.0000.0000.0006.00
set interfaces lo0 unit 6 family inet6 address 2001::6/128
set protocols rsvp interface xe-0/2/0.1
set protocols rsvp interface xe-0/3/0.5
set protocols rsvp interface xe-0/2/0.13
set protocols mpls ipv6-tunneling
set protocols mpls label-switched-path R6-R5 to 1.1.1.5
set protocols mpls label-switched-path R6-R5 primary via_R5
set protocols mpls label-switched-path R6-R5 secondary via_other standby
set protocols mpls label-switched-path R6-R7 to 1.1.1.7
set protocols mpls label-switched-path R6-R7 primary via_R7
set protocols mpls label-switched-path R6-R7 secondary via_other standby
set protocols mpls label-switched-path R6-R8 to 1.1.1.8
set protocols mpls label-switched-path R6-R8 primary via_R7
set protocols mpls label-switched-path R6-R8 secondary via_other standby
set protocols mpls path via_R5 1.1.1.5 strict
set protocols mpls path via_R7 1.1.1.7 strict
set protocols mpls path via_other
set protocols mpls interface xe-0/2/0.1
set protocols mpls interface xe-0/3/0.5
set protocols mpls interface xe-0/2/0.13
set protocols bgp group AS-65001 type internal
set protocols bgp group AS-65001 local-address 1.1.1.6
set protocols bgp group AS-65001 family inet-vpn unicast
set protocols bgp group AS-65001 family inet6-vpn unicast
set protocols bgp group AS-65001 authentication-key "$9$7eVw2ZGjikmz301RSKv"
set protocols bgp group AS-65001 neighbor 1.1.1.1
set protocols bgp group AS-65001 neighbor 1.1.1.2
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$KMV8XNsY4oJUqm6CtOEh"
set protocols isis level 2 authentication-type md5
set protocols isis interface xe-0/2/0.1 point-to-point
set protocols isis interface xe-0/2/0.1 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.1 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.1 level 1 disable
set protocols isis interface xe-0/2/0.13 point-to-point
set protocols isis interface xe-0/2/0.13 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.13 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.13 level 1 disable
set protocols isis interface xe-0/3/0.5 point-to-point
set protocols isis interface xe-0/3/0.5 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.5 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.5 level 1 disable
set protocols isis interface lo0.6 passive
set policy-options policy-statement BGP-IMPORT term SECONDARY from protocol bgp
set policy-options policy-statement BGP-IMPORT term SECONDARY then local-preference 50
set routing-instances IPVPN instance-type vrf
set routing-instances IPVPN interface xe-0/2/0.10
set routing-instances IPVPN route-distinguisher 1:1
set routing-instances IPVPN vrf-target target:1:1
set routing-instances IPVPN vrf-table-label
set routing-instances IPVPN protocols bgp group CPE type external
set routing-instances IPVPN protocols bgp group CPE passive
set routing-instances IPVPN protocols bgp group CPE authentication-key "$9$PQF6puB1RcKMVs2aDj"
set routing-instances IPVPN protocols bgp group CPE peer-as 65500
set routing-instances IPVPN protocols bgp group CPE as-override
set routing-instances IPVPN protocols bgp group CPE neighbor 2.0.0.37 metric-out 150
set routing-instances IPVPN protocols bgp group CPE neighbor 2.0.0.37 import BGP-IMPORT
set routing-instances IPVPN protocols bgp group CPE-V6 type external
set routing-instances IPVPN protocols bgp group CPE-V6 passive
set routing-instances IPVPN protocols bgp group CPE-V6 authentication-key "$9$PQF6puB1RcKMVs2aDj"
set routing-instances IPVPN protocols bgp group CPE-V6 peer-as 65500
set routing-instances IPVPN protocols bgp group CPE-V6 as-override
set routing-instances IPVPN protocols bgp group CPE-V6 neighbor 2001:2:37::10 metric-out 150
set routing-instances IPVPN protocols bgp group CPE-V6 neighbor 2001:2:37::10 import BGP-IMPORT
set routing-options autonomous-system 65001
set routing-options confederation 64512
set routing-options confederation members 65001
set routing-options confederation members 65002
                
AUGUSTUS:
 
set interfaces xe-0/2/0 unit 7 description GAIUS
set interfaces xe-0/2/0 unit 7 vlan-id 7
set interfaces xe-0/2/0 unit 7 family inet mtu 1500
set interfaces xe-0/2/0 unit 7 family inet address 2.0.0.26/30
set interfaces xe-0/2/0 unit 7 family iso
set interfaces xe-0/2/0 unit 7 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 7 family inet6 address 2001:2:25::/64 eui-64
set interfaces xe-0/2/0 unit 7 family inet6 address fe80::0007:0000:0000:0007/64
set interfaces xe-0/2/0 unit 7 family mpls
set interfaces xe-0/2/0 unit 15 description CALIGULA
set interfaces xe-0/2/0 unit 15 vlan-id 15
set interfaces xe-0/2/0 unit 15 family inet mtu 1500
set interfaces xe-0/2/0 unit 15 family inet address 2.0.0.58/30
set interfaces xe-0/2/0 unit 15 family iso
set interfaces xe-0/2/0 unit 15 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 15 family inet6 address 2001:2:57::/64 eui-64
set interfaces xe-0/2/0 unit 15 family inet6 address fe80::0015:0000:0000:0007/64
set interfaces xe-0/2/0 unit 15 family mpls
set interfaces xe-0/3/0 unit 12 description NERO
set interfaces xe-0/3/0 unit 12 vlan-id 12
set interfaces xe-0/3/0 unit 12 family inet mtu 1500
set interfaces xe-0/3/0 unit 12 family inet address 2.0.0.45/30
set interfaces xe-0/3/0 unit 12 family iso
set interfaces xe-0/3/0 unit 12 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 12 family inet6 address fe80::0012:0000:0000:0007/64
set interfaces xe-0/3/0 unit 12 family inet6 address 2001:2:45::7/64
set interfaces xe-0/3/0 unit 13 description ROMULUS
set interfaces xe-0/3/0 unit 13 vlan-id 13
set interfaces xe-0/3/0 unit 13 family inet mtu 1500
set interfaces xe-0/3/0 unit 13 family inet address 2.0.0.49/30
set interfaces xe-0/3/0 unit 13 family iso
set interfaces xe-0/3/0 unit 13 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 13 family inet6 address 2001:2:49::/64 eui-64
set interfaces xe-0/3/0 unit 13 family inet6 address fe80::0013:0000:0000:0007/64
set interfaces xe-0/3/0 unit 13 family mpls
set interfaces lo0 unit 7 family inet address 1.1.1.7/32
set interfaces lo0 unit 7 family iso address 49.0001.0000.0000.0007.00
set interfaces lo0 unit 7 family inet6 address 2001::7/128
set protocols rsvp interface xe-0/2/0.7
set protocols rsvp interface xe-0/2/0.15
set protocols rsvp interface xe-0/3/0.13
set protocols mpls traceoptions file mpls_augustus
set protocols mpls traceoptions flag cspf
set protocols mpls traceoptions flag cspf-link
set protocols mpls traceoptions flag cspf-node
set protocols mpls ipv6-tunneling
set protocols mpls label-switched-path R7-R5 to 1.1.1.5
set protocols mpls label-switched-path R7-R5 primary via_R6
set protocols mpls label-switched-path R7-R5 secondary via_other standby
set protocols mpls label-switched-path R7-R6 to 1.1.1.6
set protocols mpls label-switched-path R7-R6 primary via_R6
set protocols mpls label-switched-path R7-R6 secondary via_other standby
set protocols mpls label-switched-path R7-R8 to 1.1.1.8
set protocols mpls label-switched-path R7-R8 primary via_R8
set protocols mpls label-switched-path R7-R8 secondary via_other standby
set protocols mpls path via_R8 1.1.1.8 strict
set protocols mpls path via_R6 1.1.1.6 strict
set protocols mpls path via_other
set protocols mpls interface xe-0/2/0.7
set protocols mpls interface xe-0/2/0.15
set protocols mpls interface xe-0/3/0.13
set protocols bgp group AS-65002 type internal
set protocols bgp group AS-65002 local-address 1.1.1.7
set protocols bgp group AS-65002 family inet-vpn unicast
set protocols bgp group AS-65002 family inet6-vpn unicast
set protocols bgp group AS-65002 authentication-key "$9$7eVw2ZGjikmz301RSKv"
set protocols bgp group AS-65002 neighbor 1.1.1.3
set protocols bgp group AS-65002 neighbor 1.1.1.4
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$KMV8XNsY4oJUqm6CtOEh"
set protocols isis level 2 authentication-type md5
set protocols isis interface xe-0/2/0.7 point-to-point
set protocols isis interface xe-0/2/0.7 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.7 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.7 level 1 disable
set protocols isis interface xe-0/2/0.15 point-to-point
set protocols isis interface xe-0/2/0.15 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.15 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.15 level 1 disable
set protocols isis interface xe-0/3/0.13 point-to-point
set protocols isis interface xe-0/3/0.13 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.13 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.13 level 1 disable
set protocols isis interface lo0.7 passive
set routing-instances IPVPN instance-type vrf
set routing-instances IPVPN interface xe-0/3/0.12
set routing-instances IPVPN route-distinguisher 1:1
set routing-instances IPVPN vrf-target target:1:1
set routing-instances IPVPN vrf-table-label
set routing-instances IPVPN protocols bgp group CPE type external
set routing-instances IPVPN protocols bgp group CPE passive
set routing-instances IPVPN protocols bgp group CPE authentication-key "$9$PQF6puB1RcKMVs2aDj"
set routing-instances IPVPN protocols bgp group CPE peer-as 65500
set routing-instances IPVPN protocols bgp group CPE as-override
set routing-instances IPVPN protocols bgp group CPE neighbor 2.0.0.46
set routing-instances IPVPN protocols bgp group CPE-V6 type external
set routing-instances IPVPN protocols bgp group CPE-V6 passive
set routing-instances IPVPN protocols bgp group CPE-V6 authentication-key "$9$PQF6puB1RcKMVs2aDj"
set routing-instances IPVPN protocols bgp group CPE-V6 peer-as 65500
set routing-instances IPVPN protocols bgp group CPE-V6 as-override
set routing-instances IPVPN protocols bgp group CPE-V6 neighbor 2001:2:45::11
set routing-options autonomous-system 65002
set routing-options confederation 64512
set routing-options confederation members 65001
set routing-options confederation members 65002
                
TIBERIUS:
 
set interfaces xe-0/2/0 unit 3 description REMUS
set interfaces xe-0/2/0 unit 3 vlan-id 3
set interfaces xe-0/2/0 unit 3 family inet mtu 1500
set interfaces xe-0/2/0 unit 3 family inet address 2.0.0.10/30
set interfaces xe-0/2/0 unit 3 family iso
set interfaces xe-0/2/0 unit 3 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 3 family inet6 address fe80::0003:0000:0000:0013/64
set interfaces xe-0/2/0 unit 3 family inet6 address 2001:2:9::9/64
set interfaces xe-0/2/0 unit 18 description HADRIAN_VESPASIAN
set interfaces xe-0/2/0 unit 18 vlan-id 18
set interfaces xe-0/2/0 unit 18 family inet mtu 1500
set interfaces xe-0/2/0 unit 18 family inet address 3.0.0.2/29 vrrp-group 1 virtual-address 3.0.0.6
set interfaces xe-0/2/0 unit 18 family inet address 3.0.0.2/29 vrrp-group 1 priority 250
set interfaces xe-0/2/0 unit 18 family iso
set interfaces xe-0/2/0 unit 18 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 18 family inet6 address fe80::0018:0000:0000:0009/64
set interfaces xe-0/2/0 unit 18 family inet6 address 2001:3:1::9/64 vrrp-inet6-group 6 virtual-inet6-address 2001:3:1::1
set interfaces xe-0/2/0 unit 18 family inet6 address 2001:3:1::9/64 vrrp-inet6-group 6 virtual-link-local-address fe80::0018:0000:0000:0001
set interfaces xe-0/2/0 unit 18 family inet6 address 2001:3:1::9/64 vrrp-inet6-group 6 priority 250
set interfaces lo0 unit 9 family inet address 1.1.1.9/32
set interfaces lo0 unit 9 family inet6 address 2001::9/128
set protocols bgp group PE type external
set protocols bgp group PE authentication-key "$9$MA-X7d2gaJGjmf9tu1cS"
set protocols bgp group PE export BGP-EXPORT
set protocols bgp group PE peer-as 64512
set protocols bgp group PE neighbor 2.0.0.9
set protocols bgp group CPE-iBGP type internal
set protocols bgp group CPE-iBGP authentication-key "$9$ty05O1EleMWL7wYDHqfF3"
set protocols bgp group CPE-iBGP export iBGP-EXPORT
set protocols bgp group CPE-iBGP peer-as 65500
set protocols bgp group CPE-iBGP neighbor 3.0.0.1
set protocols bgp group PE-V6 type external
set protocols bgp group PE-V6 authentication-key "$9$MA-X7d2gaJGjmf9tu1cS"
set protocols bgp group PE-V6 export BGP-EXPORT-V6
set protocols bgp group PE-V6 peer-as 64512
set protocols bgp group PE-V6 neighbor 2001:2:9::5
set policy-options policy-statement BGP-EXPORT term Lo0 from interface lo0.9
set policy-options policy-statement BGP-EXPORT term Lo0 then accept
set policy-options policy-statement BGP-EXPORT term VRRP-SUBNET from protocol direct
set policy-options policy-statement BGP-EXPORT term VRRP-SUBNET from route-filter 3.0.0.0/29 exact
set policy-options policy-statement BGP-EXPORT term VRRP-SUBNET then accept
set policy-options policy-statement BGP-EXPORT term STATIC from protocol static
set policy-options policy-statement BGP-EXPORT term STATIC from route-filter 1.1.1.13/32 exact
set policy-options policy-statement BGP-EXPORT term STATIC then accept
set policy-options policy-statement BGP-EXPORT-V6 term Lo0 from interface lo0.9
set policy-options policy-statement BGP-EXPORT-V6 term Lo0 then accept
set policy-options policy-statement BGP-EXPORT-V6 term VRRP-SUBNET from protocol direct
set policy-options policy-statement BGP-EXPORT-V6 term VRRP-SUBNET from route-filter 2001:3:1::/64 exact
set policy-options policy-statement BGP-EXPORT-V6 term VRRP-SUBNET then accept
set policy-options policy-statement BGP-EXPORT-V6 term STATIC from protocol static
set policy-options policy-statement BGP-EXPORT-V6 term STATIC from route-filter 2001::13/128 exact
set policy-options policy-statement BGP-EXPORT-V6 term STATIC then accept
set policy-options policy-statement iBGP-EXPORT term all then next-hop self
set routing-options rib inet6.0 static route 2001::13/128 next-hop 2001:3:1::13
set routing-options static route 1.1.1.13/32 next-hop 3.0.0.3
set routing-options autonomous-system 65500
                
HADRIAN:
 
set interfaces xe-0/3/0 unit 10 description ROMULUS
set interfaces xe-0/3/0 unit 10 vlan-id 10
set interfaces xe-0/3/0 unit 10 family inet mtu 1500
set interfaces xe-0/3/0 unit 10 family inet address 2.0.0.37/30
set interfaces xe-0/3/0 unit 10 family iso
set interfaces xe-0/3/0 unit 10 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 10 family inet6 address fe80::0010:0000:0000:0010/64
set interfaces xe-0/3/0 unit 10 family inet6 address 2001:2:37::10/64
set interfaces xe-0/3/0 unit 11 description NERO
set interfaces xe-0/3/0 unit 11 vlan-id 11
set interfaces xe-0/3/0 unit 11 family inet mtu 1500
set interfaces xe-0/3/0 unit 11 family inet address 2.0.0.41/30
set interfaces xe-0/3/0 unit 11 family iso
set interfaces xe-0/3/0 unit 11 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 11 family inet6 address 2001:2:41::/64 eui-64
set interfaces xe-0/3/0 unit 11 family inet6 address fe80::0011:0000:0000:0010/64
set interfaces xe-0/3/0 unit 18 description TIBERIUS_HADRIAN
set interfaces xe-0/3/0 unit 18 vlan-id 18
set interfaces xe-0/3/0 unit 18 family inet mtu 1500
set interfaces xe-0/3/0 unit 18 family inet address 3.0.0.1/29 vrrp-group 1 virtual-address 3.0.0.6
set interfaces xe-0/3/0 unit 18 family inet address 3.0.0.1/29 vrrp-group 1 priority 50
set interfaces xe-0/3/0 unit 18 family iso
set interfaces xe-0/3/0 unit 18 family inet6 address 2001:3:1::10/64 vrrp-inet6-group 6 virtual-inet6-address 2001:3:1::1
set interfaces xe-0/3/0 unit 18 family inet6 address 2001:3:1::10/64 vrrp-inet6-group 6 virtual-link-local-address fe80::0018:0000:0000:0001
set interfaces xe-0/3/0 unit 18 family inet6 address 2001:3:1::10/64 vrrp-inet6-group 6 priority 175
set interfaces xe-0/3/0 unit 18 family inet6 address fe80::0018:0000:0000:0010/64
set interfaces lo0 unit 10 family inet address 1.1.1.10/32
set interfaces lo0 unit 10 family inet6 address 2001::10/128
set protocols bgp group PE type external
set protocols bgp group PE authentication-key "$9$MA-X7d2gaJGjmf9tu1cS"
set protocols bgp group PE export BGP-EXPORT
set protocols bgp group PE peer-as 64512
set protocols bgp group PE neighbor 2.0.0.38
set protocols bgp group CPE-iBGP type internal
set protocols bgp group CPE-iBGP authentication-key "$9$ty05O1EleMWL7wYDHqfF3"
set protocols bgp group CPE-iBGP export iBGP-EXPORT
set protocols bgp group CPE-iBGP peer-as 65500
set protocols bgp group CPE-iBGP neighbor 3.0.0.2
set protocols bgp group PE-V6 type external
set protocols bgp group PE-V6 authentication-key "$9$MA-X7d2gaJGjmf9tu1cS"
set protocols bgp group PE-V6 export BGP-EXPORT-V6
set protocols bgp group PE-V6 peer-as 64512
set protocols bgp group PE-V6 neighbor 2001:2:37::6
set policy-options policy-statement BGP-EXPORT term Lo0 from interface lo0.10
set policy-options policy-statement BGP-EXPORT term Lo0 then accept
set policy-options policy-statement BGP-EXPORT term VRRP-SUBNET from protocol direct
set policy-options policy-statement BGP-EXPORT term VRRP-SUBNET from route-filter 3.0.0.0/29 exact
set policy-options policy-statement BGP-EXPORT term VRRP-SUBNET then accept
set policy-options policy-statement BGP-EXPORT term STATIC from protocol static
set policy-options policy-statement BGP-EXPORT term STATIC from route-filter 1.1.1.13/32 exact
set policy-options policy-statement BGP-EXPORT term STATIC then accept
set policy-options policy-statement BGP-EXPORT-V6 term Lo0 from interface lo0.10
set policy-options policy-statement BGP-EXPORT-V6 term Lo0 then accept
set policy-options policy-statement BGP-EXPORT-V6 term VRRP-SUBNET from protocol direct
set policy-options policy-statement BGP-EXPORT-V6 term VRRP-SUBNET from route-filter 2001:3:1::/64 exact
set policy-options policy-statement BGP-EXPORT-V6 term VRRP-SUBNET then accept
set policy-options policy-statement BGP-EXPORT-V6 term STATIC from protocol static
set policy-options policy-statement BGP-EXPORT-V6 term STATIC from route-filter 2001::13/128 exact
set policy-options policy-statement BGP-EXPORT-V6 term STATIC then accept
set policy-options policy-statement iBGP-EXPORT term all then next-hop self
set routing-options rib inet6.0 static route 2001::13/128 next-hop 2001:3:1::13
set routing-options static route 1.1.1.13/32 next-hop 3.0.0.3
set routing-options autonomous-system 65500
                
NERO:
 
set interfaces xe-0/2/0 unit 11 description HADRIAN
set interfaces xe-0/2/0 unit 11 vlan-id 11
set interfaces xe-0/2/0 unit 11 family inet mtu 1500
set interfaces xe-0/2/0 unit 11 family inet address 2.0.0.42/30
set interfaces xe-0/2/0 unit 11 family iso
set interfaces xe-0/2/0 unit 11 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 11 family inet6 address 2001:2:41::/64 eui-64
set interfaces xe-0/2/0 unit 11 family inet6 address fe80::0011:0000:0000:0011/64
set interfaces xe-0/2/0 unit 12 description AUGUSTUS
set interfaces xe-0/2/0 unit 12 vlan-id 12
set interfaces xe-0/2/0 unit 12 family inet mtu 1500
set interfaces xe-0/2/0 unit 12 family inet address 2.0.0.46/30
set interfaces xe-0/2/0 unit 12 family iso
set interfaces xe-0/2/0 unit 12 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 12 family inet6 address fe80::0012:0000:0000:0011/64
set interfaces xe-0/2/0 unit 12 family inet6 address 2001:2:45::11/64
set interfaces lo0 unit 11 family inet address 1.1.1.11/32
set interfaces lo0 unit 11 family inet6 address 2001::11/128
set protocols bgp group PE type external
set protocols bgp group PE authentication-key "$9$MA-X7d2gaJGjmf9tu1cS"
set protocols bgp group PE export BGP-EXPORT
set protocols bgp group PE peer-as 64512
set protocols bgp group PE neighbor 2.0.0.45
set protocols bgp group PE-V6 type external
set protocols bgp group PE-V6 authentication-key "$9$MA-X7d2gaJGjmf9tu1cS"
set protocols bgp group PE-V6 export BGP-EXPORT
set protocols bgp group PE-V6 peer-as 64512
set protocols bgp group PE-V6 neighbor 2001:2:45::7
set policy-options policy-statement BGP-EXPORT term Lo0 from interface lo0.11
set policy-options policy-statement BGP-EXPORT term Lo0 then accept
set routing-options autonomous-system 65500
                
VESPASIAN:
 
set interfaces xe-0/3/0 unit 20 description CONSTANTINE
set interfaces xe-0/3/0 unit 20 vlan-id 20
set interfaces xe-0/3/0 unit 20 family inet mtu 1500
set interfaces xe-0/3/0 unit 20 family inet address 2.0.0.69/30
set interfaces xe-0/3/0 unit 20 family iso
set interfaces xe-0/3/0 unit 20 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 20 family inet6 address 2001:2:69::/64 eui-64
set interfaces xe-0/3/0 unit 20 family inet6 address fe80::0020:0000:0000:0013/64
set interfaces ae1 unit 18 description TIBERIUS_VESPASION
set interfaces ae1 unit 18 vlan-id 18
set interfaces ae1 unit 18 family inet mtu 1500
set interfaces ae1 unit 18 family inet address 3.0.0.3/29
set interfaces ae1 unit 18 family iso
set interfaces ae1 unit 18 family inet6 mtu 1500
set interfaces ae1 unit 18 family inet6 address fe80::0018:0000:0000:0013/64
set interfaces ae1 unit 18 family inet6 address 2001:3:1::13/64
set interfaces lo0 unit 13 family inet address 1.1.1.13/32
set interfaces lo0 unit 13 family inet6 address 2001::13/128
set routing-options rib inet6.0 static route ::/0 next-hop 2001:3:1::1
set routing-options static route 0.0.0.0/0 next-hop 3.0.0.6
                
GAIUS:
 
set interfaces xe-0/3/0 unit 6 description TRAJAN
set interfaces xe-0/3/0 unit 6 vlan-id 6
set interfaces xe-0/3/0 unit 6 family inet mtu 1500
set interfaces xe-0/3/0 unit 6 family inet address 2.0.0.21/30
set interfaces xe-0/3/0 unit 6 family iso
set interfaces xe-0/3/0 unit 6 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 6 family inet6 address 2001:2:21::/64 eui-64
set interfaces xe-0/3/0 unit 6 family inet6 address fe80::0006:0000:0000:0003/64
set interfaces xe-0/3/0 unit 6 family mpls
set interfaces xe-0/3/0 unit 7 description AUGUSTUS
set interfaces xe-0/3/0 unit 7 vlan-id 7
set interfaces xe-0/3/0 unit 7 family inet mtu 1500
set interfaces xe-0/3/0 unit 7 family inet address 2.0.0.25/30
set interfaces xe-0/3/0 unit 7 family iso
set interfaces xe-0/3/0 unit 7 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 7 family inet6 address 2001:2:25::/64 eui-64
set interfaces xe-0/3/0 unit 7 family inet6 address fe80::0007:0000:0000:0003/64
set interfaces xe-0/3/0 unit 7 family mpls
set interfaces xe-0/3/0 unit 8 description COMMODUS
set interfaces xe-0/3/0 unit 8 vlan-id 8
set interfaces xe-0/3/0 unit 8 family inet mtu 1500
set interfaces xe-0/3/0 unit 8 family inet address 2.0.0.29/30
set interfaces xe-0/3/0 unit 8 family iso
set interfaces xe-0/3/0 unit 8 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 8 family inet6 address 2001:2:29::/64 eui-64
set interfaces xe-0/3/0 unit 8 family inet6 address fe80::0008:0000:0000:0003/64
set interfaces xe-0/3/0 unit 8 family mpls
set interfaces lo0 unit 3 family inet address 1.1.1.3/32
set interfaces lo0 unit 3 family iso address 49.0001.0000.0000.0003.00
set interfaces lo0 unit 3 family inet6 address 2001::3/128
set protocols rsvp interface xe-0/3/0.6
set protocols rsvp interface xe-0/3/0.8
set protocols rsvp interface xe-0/3/0.7
set protocols mpls ipv6-tunneling
set protocols mpls label-switched-path R3-R5 to 1.1.1.5
set protocols mpls label-switched-path R3-R6 to 1.1.1.6
set protocols mpls label-switched-path R3-R7 to 1.1.1.7
set protocols mpls label-switched-path R3-R8 to 1.1.1.8
set protocols mpls interface xe-0/3/0.6
set protocols mpls interface xe-0/3/0.8
set protocols mpls interface xe-0/3/0.7
set protocols bgp group AS-65002 type internal
set protocols bgp group AS-65002 local-address 1.1.1.3
set protocols bgp group AS-65002 family inet-vpn unicast
set protocols bgp group AS-65002 family inet6-vpn unicast
set protocols bgp group AS-65002 authentication-key "$9$7eVw2ZGjikmz301RSKv"
set protocols bgp group AS-65002 cluster 1.1.1.3
set protocols bgp group AS-65002 neighbor 1.1.1.4
set protocols bgp group AS-65002 neighbor 1.1.1.7
set protocols bgp group AS-65002 neighbor 1.1.1.8
set protocols bgp group CBGP type external
set protocols bgp group CBGP multihop
set protocols bgp group CBGP local-address 1.1.1.3
set protocols bgp group CBGP family inet-vpn unicast
set protocols bgp group CBGP family inet6-vpn unicast
set protocols bgp group CBGP authentication-key "$9$jfqm5n6CApOhSL7-w4o"
set protocols bgp group CBGP peer-as 65001
set protocols bgp group CBGP neighbor 1.1.1.2
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$KMV8XNsY4oJUqm6CtOEh"
set protocols isis level 2 authentication-type md5
set protocols isis interface xe-0/3/0.6 point-to-point
set protocols isis interface xe-0/3/0.6 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.6 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.6 level 1 disable
set protocols isis interface xe-0/3/0.7 point-to-point
set protocols isis interface xe-0/3/0.7 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.7 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.7 level 1 disable
set protocols isis interface xe-0/3/0.8 point-to-point
set protocols isis interface xe-0/3/0.8 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.8 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.8 level 1 disable
set protocols isis interface lo0.3 passive
set routing-options autonomous-system 65002
set routing-options confederation 64512
set routing-options confederation members 65001
set routing-options confederation members 65002
                
COMMODUS:
 
set interfaces xe-0/2/0 unit 8 description GAIUS
set interfaces xe-0/2/0 unit 8 vlan-id 8
set interfaces xe-0/2/0 unit 8 family inet mtu 1500
set interfaces xe-0/2/0 unit 8 family inet address 2.0.0.30/30
set interfaces xe-0/2/0 unit 8 family iso
set interfaces xe-0/2/0 unit 8 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 8 family inet6 address 2001:2:29::/64 eui-64
set interfaces xe-0/2/0 unit 8 family inet6 address fe80::0008:0000:0000:0004/64
set interfaces xe-0/2/0 unit 8 family mpls
set interfaces xe-0/2/0 unit 14 description CALIGULA
set interfaces xe-0/2/0 unit 14 vlan-id 14
set interfaces xe-0/2/0 unit 14 family inet mtu 1500
set interfaces xe-0/2/0 unit 14 family inet address 2.0.0.54/30
set interfaces xe-0/2/0 unit 14 family iso
set interfaces xe-0/2/0 unit 14 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 14 family inet6 address 2001:2:53::/64 eui-64
set interfaces xe-0/2/0 unit 14 family inet6 address fe80::0014:0000:0000:0004/64
set interfaces xe-0/2/0 unit 14 family mpls
set interfaces lo0 unit 4 family inet address 1.1.1.4/32
set interfaces lo0 unit 4 family iso address 49.0001.0000.0000.0004.00
set interfaces lo0 unit 4 family inet6 address 2001::4/128
set protocols rsvp interface xe-0/2/0.14
set protocols rsvp interface xe-0/2/0.8
set protocols mpls ipv6-tunneling
set protocols mpls label-switched-path R4-R5 to 1.1.1.5
set protocols mpls label-switched-path R4-R6 to 1.1.1.6
set protocols mpls label-switched-path R4-R7 to 1.1.1.7
set protocols mpls label-switched-path R4-R8 to 1.1.1.8
set protocols mpls interface xe-0/2/0.14
set protocols mpls interface xe-0/2/0.8
set protocols bgp group AS-65002 type internal
set protocols bgp group AS-65002 local-address 1.1.1.4
set protocols bgp group AS-65002 family inet-vpn unicast
set protocols bgp group AS-65002 family inet6-vpn unicast
set protocols bgp group AS-65002 authentication-key "$9$7eVw2ZGjikmz301RSKv"
set protocols bgp group AS-65002 cluster 1.1.1.4
set protocols bgp group AS-65002 neighbor 1.1.1.3
set protocols bgp group AS-65002 neighbor 1.1.1.7
set protocols bgp group AS-65002 neighbor 1.1.1.8
set protocols bgp group CBGP type external
set protocols bgp group CBGP multihop
set protocols bgp group CBGP local-address 1.1.1.4
set protocols bgp group CBGP family inet-vpn unicast
set protocols bgp group CBGP family inet6-vpn unicast
set protocols bgp group CBGP authentication-key "$9$jfqm5n6CApOhSL7-w4o"
set protocols bgp group CBGP peer-as 65001
set protocols bgp group CBGP neighbor 1.1.1.2
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$KMV8XNsY4oJUqm6CtOEh"
set protocols isis level 2 authentication-type md5
set protocols isis interface xe-0/2/0.8 point-to-point
set protocols isis interface xe-0/2/0.8 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.8 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.8 level 1 disable
set protocols isis interface xe-0/2/0.14 point-to-point
set protocols isis interface xe-0/2/0.14 bfd-liveness-detection version 1
set protocols isis interface xe-0/2/0.14 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/2/0.14 level 1 disable
set protocols isis interface lo0.4 passive
set routing-options autonomous-system 65002
set routing-options confederation 64512
set routing-options confederation members 65001
set routing-options confederation members 65002
                
CALIGULA:
 
set interfaces xe-0/3/0 unit 14 description COMMODUS
set interfaces xe-0/3/0 unit 14 vlan-id 14
set interfaces xe-0/3/0 unit 14 family inet mtu 1500
set interfaces xe-0/3/0 unit 14 family inet address 2.0.0.53/30
set interfaces xe-0/3/0 unit 14 family iso
set interfaces xe-0/3/0 unit 14 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 14 family inet6 address 2001:2:53::/64 eui-64
set interfaces xe-0/3/0 unit 14 family inet6 address fe80::0014:0000:0000:0008/64
set interfaces xe-0/3/0 unit 14 family mpls
set interfaces xe-0/3/0 unit 15 description AUGUSTUS
set interfaces xe-0/3/0 unit 15 vlan-id 15
set interfaces xe-0/3/0 unit 15 family inet mtu 1500
set interfaces xe-0/3/0 unit 15 family inet address 2.0.0.57/30
set interfaces xe-0/3/0 unit 15 family iso
set interfaces xe-0/3/0 unit 15 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 15 family inet6 address 2001:2:57::/64 eui-64
set interfaces xe-0/3/0 unit 15 family inet6 address fe80::0015:0000:0000:0008/64
set interfaces xe-0/3/0 unit 15 family mpls
set interfaces xe-0/3/0 unit 16 description SEPTIMUS
set interfaces xe-0/3/0 unit 16 vlan-id 16
set interfaces xe-0/3/0 unit 16 family inet mtu 1500
set interfaces xe-0/3/0 unit 16 family inet address 2.0.0.61/30
set interfaces xe-0/3/0 unit 16 family iso
set interfaces xe-0/3/0 unit 16 family inet6 mtu 1500
set interfaces xe-0/3/0 unit 16 family inet6 address fe80::0016:0000:0000:0008/64
set interfaces xe-0/3/0 unit 16 family inet6 address 2001:2:61::8/64
set interfaces lo0 unit 8 family inet address 1.1.1.8/32
set interfaces lo0 unit 8 family iso address 49.0001.0000.0000.0008.00
set interfaces lo0 unit 8 family inet6 address 2001::8/128
set protocols rsvp interface xe-0/3/0.14
set protocols rsvp interface xe-0/3/0.15
set protocols mpls ipv6-tunneling
set protocols mpls label-switched-path to_REMUS to 1.1.1.5
set protocols mpls label-switched-path to_REMUS install 2.0.0.9/32 active
set protocols mpls label-switched-path R8-R5 to 1.1.1.5
set protocols mpls label-switched-path R8-R5 primary via_R7
set protocols mpls label-switched-path R8-R5 secondary via_R4 standby
set protocols mpls label-switched-path R8-R6 to 1.1.1.6
set protocols mpls label-switched-path R8-R6 primary via_R7
set protocols mpls label-switched-path R8-R6 secondary via_R4 standby
set protocols mpls label-switched-path R8-R7 to 1.1.1.7
set protocols mpls label-switched-path R8-R7 primary via_R7
set protocols mpls label-switched-path R8-R7 secondary via_R4 standby
set protocols mpls path via_R4 1.1.1.4 strict
set protocols mpls path via_R7 1.1.1.7 strict
set protocols mpls interface xe-0/3/0.14
set protocols mpls interface xe-0/3/0.15
set protocols bgp group AS-65002 type internal
set protocols bgp group AS-65002 local-address 1.1.1.8
set protocols bgp group AS-65002 family inet-vpn unicast
set protocols bgp group AS-65002 family inet6-vpn unicast
set protocols bgp group AS-65002 authentication-key "$9$7eVw2ZGjikmz301RSKv"
set protocols bgp group AS-65002 neighbor 1.1.1.3
set protocols bgp group AS-65002 neighbor 1.1.1.4
set protocols isis lsp-lifetime 3600
set protocols isis spf-options delay 50
set protocols isis overload timeout 300
set protocols isis level 2 authentication-key "$9$KMV8XNsY4oJUqm6CtOEh"
set protocols isis level 2 authentication-type md5
set protocols isis interface xe-0/3/0.14 point-to-point
set protocols isis interface xe-0/3/0.14 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.14 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.14 level 1 disable
set protocols isis interface xe-0/3/0.15 point-to-point
set protocols isis interface xe-0/3/0.15 bfd-liveness-detection version 1
set protocols isis interface xe-0/3/0.15 bfd-liveness-detection minimum-interval 5000
set protocols isis interface xe-0/3/0.15 level 1 disable
set protocols isis interface lo0.8 passive
set routing-instances IPVPN instance-type vrf
set routing-instances IPVPN interface xe-0/3/0.16
set routing-instances IPVPN route-distinguisher 1:1
set routing-instances IPVPN vrf-target target:1:1
set routing-instances IPVPN vrf-table-label
set routing-instances IPVPN protocols bgp group CPE type external
set routing-instances IPVPN protocols bgp group CPE passive
set routing-instances IPVPN protocols bgp group CPE authentication-key "$9$PQF6puB1RcKMVs2aDj"
set routing-instances IPVPN protocols bgp group CPE peer-as 65500
set routing-instances IPVPN protocols bgp group CPE as-override
set routing-instances IPVPN protocols bgp group CPE neighbor 2.0.0.62
set routing-instances IPVPN protocols bgp group CPE-V6 type external
set routing-instances IPVPN protocols bgp group CPE-V6 passive
set routing-instances IPVPN protocols bgp group CPE-V6 authentication-key "$9$PQF6puB1RcKMVs2aDj"
set routing-instances IPVPN protocols bgp group CPE-V6 peer-as 65500
set routing-instances IPVPN protocols bgp group CPE-V6 as-override
set routing-instances IPVPN protocols bgp group CPE-V6 neighbor 2001:2:61::12
set routing-options router-id 1.1.1.8
set routing-options autonomous-system 65002
set routing-options confederation 64512
set routing-options confederation members 65001
set routing-options confederation members 65002
                
SEPTIMUS:
 
set interfaces xe-0/2/0 unit 16 description CALIGULA
set interfaces xe-0/2/0 unit 16 vlan-id 16
set interfaces xe-0/2/0 unit 16 family inet mtu 1500
set interfaces xe-0/2/0 unit 16 family inet address 2.0.0.62/30
set interfaces xe-0/2/0 unit 16 family iso
set interfaces xe-0/2/0 unit 16 family inet6 mtu 1500
set interfaces xe-0/2/0 unit 16 family inet6 address fe80::16:0000:0000:0012/64
set interfaces xe-0/2/0 unit 16 family inet6 address 2001:2:61::12/64
set interfaces lo0 unit 12 family inet address 1.1.1.12/32
set interfaces lo0 unit 12 family inet address 12.12.12.12/32
set interfaces lo0 unit 12 family inet6 address 2001::12/128
set protocols bgp group PE type external
set protocols bgp group PE authentication-key "$9$MA-X7d2gaJGjmf9tu1cS"
set protocols bgp group PE export BGP-EXPORT
set protocols bgp group PE peer-as 64512
set protocols bgp group PE neighbor 2.0.0.61
set protocols bgp group PE-V6 type external
set protocols bgp group PE-V6 authentication-key "$9$MA-X7d2gaJGjmf9tu1cS"
set protocols bgp group PE-V6 export BGP-EXPORT-V6
set protocols bgp group PE-V6 peer-as 64512
set protocols bgp group PE-V6 neighbor 2001:2:61::8
set policy-options policy-statement BGP-EXPORT term Lo0 from interface lo0.12
set policy-options policy-statement BGP-EXPORT term Lo0 from route-filter 1.1.1.12/32 exact
set policy-options policy-statement BGP-EXPORT term Lo0 then accept
set policy-options policy-statement BGP-EXPORT term STATIC from protocol static
set policy-options policy-statement BGP-EXPORT term STATIC then accept
set policy-options policy-statement BGP-EXPORT-V6 term STATIC from protocol static
set policy-options policy-statement BGP-EXPORT-V6 term STATIC then accept
set routing-options rib inet6.0 static route ::/0 reject
set routing-options static route 0.0.0.0/0 reject
set routing-options autonomous-system 65500
                

20-11-2014